eprimer3 and primer3 compatibility problem
3
0
Entering edit mode
8.3 years ago
jim • 0

I installed EMBOSS 6.6.0.0 and primer3 2.3.6 from source on a computer running Kubuntu 14.04, and set the environment variables for eprimer3 like so:

$ export EMBOSS_PRIMER3_CORE=/opt/primer3-2.3.6/src/primer3_core
$ export PRIMER_THERMODYNAMIC_PARAMETERS_PATH=/opt/primer3-2.3.6/src/primer3_config

Then I put a DNA sequence in the file in.pr3 ran this command:

$ eprimer3 -outfile=out.pr3 -sequence=in.pr3

However, this was the output:

Pick PCR primers and hybridization oligos
Error: Missing SEQUENCE tag

I cannot for the life of me figure out what the sequence tag is or how I can set it. All of the solutions on Google have failed to resolve the issue. I am led to believe that the problem has to do with incompatible versions, but someone here allegedly got this working.

Any ideas?

eprimer3 • 4.8k views
ADD COMMENT
1
Entering edit mode
8.3 years ago
Digiomics ▴ 170

The error message you get comes from primer3, not eprimer3. It means that no sequence was provided to design primers for. You get the same error message when using primer3 directly and do not set the SEQUENCE_TEMPLATE= parameter in the primer3 config file (see here)

I never tried eprimer3 before, as I only use primer3 directly, but a quick test with EMBOSS 6.3.1 and primer3 2.3.6 on my machine resulted in the same error message you got, regardless of the sequence format used ( I tested FASTA and Genbank). It hence seems like eprimer3 fails to generate a proper primer3 config file, but I don't know why.

So, unfortunately, I cannot provide a solution, except do not use eprimer3 but run primer3 directly.

ADD COMMENT
1
Entering edit mode
8.3 years ago
hpmcwill ★ 1.2k

From a quick check in the EMBOSS documentation for eprimer3, it is intended for use with the old primer3 releases (i.e. version 1 or eariler). With primer3 version 2 there were various changes to the primer3 command-line and and eprimer32 was added to EMBOSS to support the new version.

From you post it looks like you are attempting to use EMBOSS with primer3 2.3.6, in which case you will need to use eprimer32 (and the environment variable EMBOSS_PRIMER32_CORE) instead of eprimer3. The thread from the EMBOSS users mailing list that you mention ("problem with eprimer32") details how to get primer3 2.3.5 working with eprimer32, which fails in some installations due to the need to find the thermodynamic parameters and a path assumption in primer3.

For EMBOSS support try contacting the appropriate EMBOSS mailing list, you may find it helpful to search the mailing list archives. To report a problem with EMBOSS to the developers see "Reporting Bugs and Problems" in the EMBOSS documentation.

ADD COMMENT
0
Entering edit mode
7 months ago
mwylerCH • 0

Years later but I was looking for it today: eprimer32 looks for a bin called primer32_core. However, the last version of primer3 contains only the primer3_core file: Everything worked using after changing the name of primer3_core to primer32_core (and exported the path).

ADD COMMENT

Login before adding your answer.

Traffic: 694 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6