gkno install failing on [get] Getting: http://repo1.maven.org/maven2/org/apache/ivy/ivy/2.2.0/ivy-2.2.0.jar
1
0
Entering edit mode
7.5 years ago
brettin • 0

During the installation process, the following occurs:

[mkdir] Created dir: /root/.ant/lib
  [get] Getting: http://repo1.maven.org/maven2/org/apache/ivy/ivy/2.2.0/ivy-2.2.0.jar
  [get] To: /root/.ant/lib/ivy-2.2.0.jar
  [get] Error opening connection java.io.IOException: Server returned HTTP response code: 403 for URL: http://repo1.maven.org/maven2/org/apache/ivy/ivy/2.2.0/ivy-2.2.0.jar
  [get] Error opening connection java.io.IOException: Server returned HTTP response code: 403 for URL: http://repo1.maven.org/maven2/org/apache/ivy/ivy/2.2.0/ivy-2.2.0.jar
  [get] Error opening connection java.io.IOException: Server returned HTTP response code: 403 for URL: http://repo1.maven.org/maven2/org/apache/ivy/ivy/2.2.0/ivy-2.2.0.jar
  [get] Can't get http://repo1.maven.org/maven2/org/apache/ivy/ivy/2.2.0/ivy-2.2.0.jar to /root/.ant/lib/ivy-2.2.0.jar

I verified the network route by successfully running wget at the command line:

root@precise64:/home/vagrant/gkno_launcher# wget http://repo1.maven.org/maven2/org/apache/ivy/ivy/2.2.0/ivy-2.2.0.jar
gkno • 3.0k views
ADD COMMENT
0
Entering edit mode

Did Pierre's suggestion help with this problem?

ADD REPLY
1
Entering edit mode
7.5 years ago

I suspect you're working behind a proxy: configure the proxy for maven: http://maven.apache.org/guides/mini/guide-proxies.html

ADD COMMENT
0
Entering edit mode

Thank you Pierre, yes, it was a network problem related to a proxy. I didn't need to set up the proxy settings file for maven, I just changed a network configuration on our network.

ADD REPLY

Login before adding your answer.

Traffic: 3014 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6