Question: Getting zero length transcriptome with Velvet-Oases
0
gravatar for nehagoel24march
5.6 years ago by
nehagoel24march0 wrote:

Respected Sir/ Madam,
 

I am Neha Goel from India. I am working on transcriptome sequence data from 454seq. I have 10Mbps data, I preprocessed (Quality filter/ Quality Trimming) and obtained the filtered file . For Denovo assembly I chase the velvet-Oases. I installed the velvet and it gave the contig.fa and Sequences.fa,  Now I ran the command for Oases.
 

./oases 'directory name/' -merge yes -scaffolding yes -min_trans_lgth 200

But I get the transcriptes.fa with out any data (0 bytes).

I am not getting why is it so??? I ran the previous commands :

velveth dir 31 -fastq -short reads.fq
velvetg dir/ -read_trkg yes

I also have single read Roche data. Now Please guide me what should i do??

oases rna-seq • 1.8k views
ADD COMMENTlink modified 5.6 years ago • written 5.6 years ago by nehagoel24march0

Doesn't 454 data mean that we use the -long (and not the -short) flag for velveth?

ADD REPLYlink written 5.6 years ago by RamRS27k
./velveth dir 31 -fastq reads.fq
./velvetg dir/ -read_trkg yes

As the output contig.fa (13MB) and sequencs.fa (250MB)

when i am executing the command

./oases_pipeline.py -m 21 -M 23  -d dir/

(Here i gave velvet directory path) then it gives the following error:

Could not find Velvet
Make sure that it is properly installed on your path

When I set the path through command line as well as .bashrc but still its not working,

Please guide me the steps what to do..

ADD REPLYlink modified 5.6 years ago by RamRS27k • written 5.6 years ago by nehagoel24march0

Could you maybe make sure you are pointing to where the actual velveth and velvetg binaries exist and not to the parent folder by mistake please? Sometimes the binaries are nested inside a bin/ or dist/ folder and giving the parent folder does not work in these cases.

ADD REPLYlink written 5.6 years ago by RamRS27k
0
gravatar for nehagoel24march
5.6 years ago by
nehagoel24march0 wrote:

I download velvet_1.2.10 in Downloads folder and untar it., make after that i set the categories and maxkmerlength through make command. After that I ran the command velveth then it was displaying

The program 'velveth' is currently not installed. You can install it by typing:
sudo apt-get install velvet

if I am running

./velveth

this command executed..after that i ran ./velvetg and continued with ./oases . It generated the transcript.fa

If i am running oases_pipeline_python script its not executing.

Could not find Velvet
Make sure that it is properly installed on your path

Nw how can i find the number of transcripts , contigs and singletons from the contig.fa

 

ADD COMMENTlink modified 5.6 years ago by RamRS27k • written 5.6 years ago by nehagoel24march0

Hi nehagoel24march ,

Could you move this to a reply on my comment please? That would involve the following steps:

Copy the contents of your reply from this answer
Click on "Add Comment" on my comment here: C: Getting zero length transcriptome with Velvet-Oases
Paste the copied text
Click on the green "Add Comment" button

Thank you!

ADD REPLYlink written 5.6 years ago by RamRS27k

There are a couple of ways you could solve this. While you're downloading, un-archiving and building velvet just fine, you still need to add the binaries to your PATH variable. Easiest way for you is to run

sudo apt-get install velvet

and then try running oases_pipeline.py

ADD REPLYlink written 5.6 years ago by RamRS27k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 2082 users visited in the last hour