Cannot run UNAfold, error in shared library
1
0
Entering edit mode
7.6 years ago
juanma_lace ▴ 20

I'm having troubles running UNAFold.

I'm executing a perl script (sumirofold.pl) that calls for a UNAFold query. The UNAFold return an error as next:

perl /usr/bin/UNAFold.pl -X 1 --ann ss-count 1_scaffold01901.fsa
Checking for boxplot_ng... found, supports Postscript
Checking for hybrid-plot-ng... hybrid-plot-ng: error while loading shared libraries: libgd.so.2: cannot open shared object file: No such file or directory
found, supports Postscript
Checking for sir_graph_ng or sir_graph... found, supports Postscript
Checking for ps2pdfwr... found
Couldn't read 1_scaffold01901.fsa.plot: No such file or directory at /usr/bin/h-num.pl line 16.
Exit status 2 from h-num.pl

I have installed all required dependencies but still cannot execute the script.

Thank you

unafold ChIP-Seq RNA-Seq • 2.3k views
ADD COMMENT
0
Entering edit mode
7.6 years ago
hpmcwill ★ 1.2k

From the error messages it appears that the 'hybrid-plot-ng' component of UNAFold requires the GD library.

The GD library can be installed by:

A. Debian based Linux systems (e.g. Debian Linux, Ubuntu, Linux Mint, Bio-Linux, etc.)

sudo apt-get install libgd2-xpm

B. RedHat based Linux systems (e.g. RHEL, Fedora, etc.)

yum install gd

C. For other platforms or Linux distributions check the package repositories for suitable packages. If absolutely necessary you can try compiling from source (see http://www.libgd.org/).

ADD COMMENT

Login before adding your answer.

Traffic: 2034 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6