Question: help: smartpca plot population shift problem
1
gravatar for Zhenyu Zhang
4.2 years ago by
Zhenyu Zhang250
United States
Zhenyu Zhang250 wrote:

https://github.com/ZhenyuZ/eqtl/blob/master/other/temp.png

Help! I am doing some regular genotype population stratification using smartpca from EIGENSTRAT 5.01.  The plot of PC2 ~ PC1 looks like the picture.  The color ones are hapmap (blue/lightblue: euro; greenish: asian; redish: blacks; purple: mexican).  The grey ones are my samples.  There is a shift of coordinates, which indicates something wrong.  Does anyone have any idea about the problem?

Details of what I did: I got my sample genotypes, merge with hapmap ones.  There are some snp with strand flips, and I have tried both flip or just filter out.   Also I have tried to whether remove long-range LD regions; whether to prune local LD SNPs, etc.  No matter how I do it, the figure looks like this.  

 

 

 

ADD COMMENTlink modified 4.2 years ago • written 4.2 years ago by Zhenyu Zhang250

might be some kind of batch effect in your samples that is driving the PCA

ADD REPLYlink written 4.2 years ago by Ying W3.9k

Could the problem be the hapmap is with grch36, and mine sample with grch37?  

I did the merge by their rs names, so I initially thought it's not an issue. 

ADD REPLYlink written 4.2 years ago by Zhenyu Zhang250
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 774 users visited in the last hour