how to run repeatmasker
2
1
Entering edit mode
7.3 years ago
Kumar ▴ 140

Hi,

I installed repearmasker. How can run it with my genomic sequence to mask.

thanks

genome gene • 7.6k views
ADD COMMENT
0
Entering edit mode

Hi,

RepeatMasker seems to install properly, see the following message. However still it is same above error showing...

Congratulations!  RepeatMasker is now ready to use.
The program is installed with a full version of the repeat library:
  DFAM Library Version = Dfam_1.2
  RMLibrary Version = 20150807
  Repbase Version = 20150807
Further documentation on the program may be found here:
  /home/sekhwalm/Downloads/RepeatMasker/repeatmasker.help
ADD REPLY
0
Entering edit mode

Take a look at the error messages, they indicate that RM is not installed properly because it can't find the species library file and there is a problem loading a system library. You'll have to work on those issues individually, and I suggest running some tests to see it is working. Also, respond to comments by hitting reply, not posting a comment as an answer.

ADD REPLY
0
Entering edit mode
7.3 years ago

Try to get this paper for detailed usage. otherwise spend some time reading http://www.repeatmasker.org/webrepeatmaskerhelp.html

ADD COMMENT
0
Entering edit mode

This looks like it might be a link to a pirated book chapter. Maybe it would be better to link to the repeatmasker site?

ADD REPLY
0
Entering edit mode

yeah. true. updated my post.

ADD REPLY
0
Entering edit mode
7.3 years ago
SES 8.5k

The only argument you need is the genome:

RepeatMasker genome.fas

There are other options to refine the masking to one species, repeat type, or incorporate a custom repeat library (simply typing the name of the program will tell you the usage).

ADD COMMENT
0
Entering edit mode

Thanks for reply. while run the following command it is showing error. However I have current repbase lib.

./RepeatMasker -species arabidopsis dna_all.fa

RepeatMasker version open-4.0.5
Search Engine: NCBI/RMBLAST [ error while loading shared libraries: libpcre.so.0: cannot open shared object file: No such file or directory ]
Master RepeatMasker Database: /home/sekhwalm/Downloads/RepeatMasker/Libraries/RepeatMaskerLib.embl ( Complete Database: 20150807 )

Building general libraries in: /home/sekhwalm/Downloads/RepeatMasker/Libraries/20150807/general
RepeatMasker::createLib(): Error invoking /usr/local/bin/RMBlast/bin/makeblastdb on file /home/sekhwalm/Downloads/RepeatMasker/Libraries/20150807/general/at.lib.
ADD REPLY
0
Entering edit mode

There are at least two issues with your installation: missing dependencies (blast), and missing libraries or incompatible libraries for the version of RM you downloaded. I'd suggest following all the steps to install RM, and search the web for the common causes of these errors (you should find a solution very quickly).

ADD REPLY
0
Entering edit mode

thanks. Now It runs....RepeatMasker is required combination of ncbi-blast and rmblast-2.2.28.

ADD REPLY

Login before adding your answer.

Traffic: 1925 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6