Question: PLINK Merge error: File write failure
1
gravatar for aritra90
3.5 years ago by
aritra9040
United States
aritra9040 wrote:

Hi, 

I am trying two merge 1000Genomes with another already merged data set using PLINK 1.9. I am flipping and excluding variants as described in the PLINK 1.9 Data Management page. 

plink --bfile source2 --flip merged.missnp --make-bed --out source2_trial

plink --bfile source1 --bmerge source2_trial --make-bed --out merged_trial

Then, excluding merged-trial.missnp from both the files and eventually merging. However, I am getting a unique error with the 1000Genomes data set. 

I am attaching the log here for better understanding of the error. 

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------

./plink --bfile 1000Genomes --exclude trial2-merge.missnp --make-bed --out source1_tmp
PLINK v1.90b3w 64-bit (3 Sep 2015)         https://www.cog-genomics.org/plink2
(C) 2005-2015 Shaun Purcell, Christopher Chang   GNU General Public License v3
Logging to source1_tmp.log.
Options in effect:
  --bfile 1000Genomes
  --exclude trial2-merge.missnp
  --make-bed
  --out source1_tmp

257857 MB RAM detected; reserving 128928 MB for main workspace.
39517397 variants loaded from .bim file.
2504 people (1233 males, 1271 females) loaded from .fam.
2504 phenotype values loaded from .fam.
--exclude: 39514129 variants remaining.
Using 1 thread (no multithreaded calculations invoked.
Before main variant filters, 2504 founders and 0 nonfounders present.
Calculating allele frequencies... done.
Total genotyping rate is 0.9997.
39514129 variants and 2504 people pass filters and QC.
Among remaining phenotypes, 0 are cases and 2504 are controls.
--make-bed to source1_tmp.bed + source1_tmp.bim + source1_tmp.fam ... 79%
Error: File write failure.
Error: Failed to finish writing to log.

---------------------------------------------------------------------------------------------------------------------------------------------------------------

I have no clue why its failing at 79%. This procedure has worked for other data sets, but not this particular data set. It would be great if someone can give me some insight on this. 

Thanks, 

Aritra

plink 1000genomes • 2.8k views
ADD COMMENTlink modified 3.5 years ago • written 3.5 years ago by aritra9040
3

Do you have enough disk space/disk quota?

ADD REPLYlink written 3.5 years ago by chrchang5234.9k

Thanks ! It turned out to be just that. :)

ADD REPLYlink written 3.5 years ago by aritra9040
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1608 users visited in the last hour