Cutadapt installation problem
2
0
Entering edit mode
6.0 years ago
e.antoun ▴ 20

Hi,

I am attempting to install the latest version of cutadapt (1.9) using the source code. I have downloaded cutadapt-1.9.tar.gz, extracted it and ran the following:

python setup.py install --user.

 

Cutadapt install fine, but then when I check the version, it says I have installed version 1.3. I then try the following:

pip install --user --upgrade cutadapt

to see if it will upgrade the program, but it does nothing and I still only have version 1.3 installed.

 

Can anyone help m with how to get the latest version of cutadapt? I am running python 2.7 so it should work fine.

 

Thanks

 

cutadapt • 2.6k views
ADD COMMENT
0
Entering edit mode
6.0 years ago

Make sure version 1.3 doesn't come before 1.9 in your PATH. Look at the output of 'which cutadapt' and 'echo $PATH'

ADD COMMENT
0
Entering edit mode

Thanks for the reply.

The output of which cutadapt is: /local/software/python/2.7.5/bin/cutadapt

and echo $PATH gives:

/local/software/python/2.7.5/bin/:/usr/lib64/qt-3.3/bin:/local/software/moab/default/sbin:/local/software/moab/default/bin:/local/software/torque/default/sbin:/local/software/torque/default/bin:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/usr/lpp/mmfs/bin

From that, neither version is in my PATH. So would I need to put 1.9 into my PATH for it to work?

ADD REPLY
0
Entering edit mode
6.0 years ago
e.antoun ▴ 20

Problem solved, I needed to put my locally installed cutadapt version into my PATH, as the older version was installed on the system that I don't have admin access to.

ADD COMMENT

Login before adding your answer.

Traffic: 1158 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6