Question: DeepTools Error: Be sure that the bam files you are using is indexed.
0
gravatar for dally
3.8 years ago by
dally180
United States
dally180 wrote:

I am attempting to use the bamCorrelate function of deeptools to find the reproducibility between two chip seq replicates.

I have used samtools index BAMFILE to index my files, but I am still running into this error so I must not be doing this correctly.

Here is the command I used for deeptools

bamCorrelate bins --bamfiles /Volumes/mydata/2015108/IDRM/2015_10_21_0/analysis_results/Sample_Pol_II_9_29/Alignments/Pol_II_9_29.mapped.rgid.sorted.filtered.dups_remove.bam.bai /Users/jonathanreeder/carlos-projects/Dropbox/ChIP-Seq/hg19/old_data/Sample_Pol-II-Chip-N20/Alignments/Pol-II-Chip.mapped.rgid.sorted.filtered.dups_remove.bam.bai -out pol-correlation

Here's the error:

Be sure that the bam file you areusing is indexed.

 

deeptools • 1.5k views
ADD COMMENTlink modified 3.8 years ago by matted7.1k • written 3.8 years ago by dally180
2
gravatar for matted
3.8 years ago by
matted7.1k
Boston, United States
matted7.1k wrote:

You are giving it the index files (*.bam.bai), when you should probably be giving it the bam files (*.bam).

ADD COMMENTlink written 3.8 years ago by matted7.1k

Ahh I see. I fixed that and was able to run the command line just fine. However, I can't seem to get it to work when running the --corMethod pearson parameters. It keeps telling me that it is an unrecognized argument. But everything on the github has the parameters written exactly like this. Any ideas?

 

The --plotFile command appears to be unrecognized as well.

ADD REPLYlink modified 3.8 years ago • written 3.8 years ago by dally180

I'm not sure.  Maybe you have an old version installed?

ADD REPLYlink written 3.8 years ago by matted7.1k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1523 users visited in the last hour