featureCounts isn't working how I expect
1
0
Entering edit mode
7.0 years ago
jrbustosm • 0

I'm runnig next command

featureCounts -s 1 -t exon -g Parent -a test.gff -o test.counts test.sam

in test.sam

HWI-ST568:115:D04H3ACXX:7:1101:5518:2079    0   gi|448814763|ref|NC_000962.3|   2125761 255 61M *   0   0   TGGACAAGCTAGGAGAGGAGCTTTACTCGGCGCAGTGCGTCTCTCGCCCACCGACCTGATG   CCCFFFFFHDBHHIGFHIEGHIIJCCGHHJHHJBHGHGIGGIDGGGGHGAEFFDDDDDDDD   XA:i:0  MD:Z:61 NM:i:0

in test.gff

TEST    GenBank exon    2125761 2504608 .   -   .   Parent "XXX" 

I get in test.counts,

# Program:featureCounts v1.5.0; Command:"featureCounts" "-s" "1" "-t" "exon" "-g" "Parent" "-a" "test.gff" "-o" "test.counts" "test.sam" 
Geneid  Chr Start   End Strand  Length  test.sam
XXX TEST    2125761 2504608 -   378848  0

I expected,

# Program:featureCounts v1.5.0; Command:"featureCounts" "-s" "1" "-t" "exon" "-g" "Parent" "-a" "test.gff" "-o" "test.counts" "test.sam" 
Geneid  Chr Start   End Strand  Length  test.sam
XXX TEST    2125761 2504608 -   378848  1

What's the mistake that I'm making?

rna-seq alignment • 1.8k views
ADD COMMENT
1
Entering edit mode

Aside from the chromosome name issue, I imagine that the strandedness setting would cause problems as well.

ADD REPLY
0
Entering edit mode

You are right ..... this is the problem thanks

ADD REPLY
3
Entering edit mode
7.0 years ago
Martombo ★ 3.0k

The chromosome should be "TEST" in the sam file

ADD COMMENT
0
Entering edit mode
"gi|448814763|ref|TEST|"

instead of

"gi|448814763|ref|NC_000962.3|"

?

ADD REPLY
1
Entering edit mode

Just "TEST", unless you edited things to remove gi|448814763|ref|NC_000962.3| from the GFF file snippet you posted.

ADD REPLY
0
Entering edit mode

thanks @Martombo, @Devon Ryan this solved my problem

ADD REPLY

Login before adding your answer.

Traffic: 2648 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6