Question: Error when install ggbio
0
gravatar for syrttgump
3.1 years ago by
syrttgump30
USA/Newark/New Jersey Institute of Technology
syrttgump30 wrote:

Hi everyone,

I am using the newest version of R and trying to install ggbio, here is my problem:

> biocLite("ggbio")
BioC_mirror: https://bioconductor.org
Using Bioconductor 3.2 (BiocInstaller 1.20.1), R 3.2.3 (2015-12-10).
Installing package(s) ‘ggbio’
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0100 1259k  100 1259k    0     0  1057k      0  0:00:01  0:00:01 --:--:-- 1057k
* installing *source* package ‘ggbio’ ...
** R
** inst
** preparing package for lazy loading
Warning: replacing previous import by ‘grid::arrow’ when loading ‘GGally’
Warning: replacing previous import by ‘grid::unit’ when loading ‘GGally’
Warning: replacing previous import by ‘ggplot2::unit’ when loading ‘ggbio’
Warning: replacing previous import by ‘ggplot2::arrow’ when loading ‘ggbio’
Warning: replacing previous import by ‘BiocGenerics::Position’ when loading ‘ggbio’
Creating a new generic function for ‘rescale’ in package ‘ggbio’
Creating a new generic function for ‘xlim’ in package ‘ggbio’
Creating a generic function for ‘print’ from package ‘base’ in package ‘ggbio’
Warning: 'eval' is deprecated.
Use 'plotIdeogram' instead.
See help("Deprecated")
Error in rematchDefinition(definition, fdef, mnames, fnames, signature) : 
  arguments (environment) after '...' in the generic must appear in the method, in the same place at the end of the argument list
Error : unable to load R code in package ‘ggbio’
ERROR: lazy loading failed for package ‘ggbio’
* removing ‘/usr/local/lib/R/3.2/site-library/ggbio’

The downloaded source packages are in
    ‘/private/var/folders/gb/vd06k92974n6yp3bshy0rh9w0000gn/T/RtmpynGNyF/downloaded_packages’
Warning message:
In install.packages(pkgs = doing, lib = lib, ...) :
  installation of package ‘ggbio’ had non-zero exit status

The output of session information:

 

R version 3.2.3 (2015-12-10)
Platform: x86_64-apple-darwin15.2.0 (64-bit)
Running under: OS X 10.11.2 (El Capitan)

locale:
[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] stats4    parallel  stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] GenomicRanges_1.22.2 GenomeInfoDb_1.6.1   IRanges_2.4.6        S4Vectors_0.8.5     
[5] BiocGenerics_0.16.1  edgeR_3.12.0         limma_3.26.3         BiocInstaller_1.20.1

loaded via a namespace (and not attached):
[1] zlibbioc_1.16.0 XVector_0.10.0  tools_3.2.3   
 
ggplot ggbio latest • 1.6k views
ADD COMMENTlink modified 16 months ago by Biostar ♦♦ 20 • written 3.1 years ago by syrttgump30
1

Hi, you appear to have cross-posted this to the bioconductor message-boards and received an answer (although that answer didn't help me install ggbio)

ADD REPLYlink written 3.1 years ago by russhh4.1k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1306 users visited in the last hour