Question: Cutadapt 1.9.1 error
0
gravatar for vishweshwaransridhar
2.8 years ago by
Singapore
vishweshwaransridhar10 wrote:

Hi,

When i try to use cutadapt without installation I get the following error.

[USER@user cutadapt-1.9.1]$ python2.6 ./bin/cutadapt --help

ERROR: A required extension module could not be imported because it is
incompatible with your system. A quick fix is to recompile the extension
modules with the following command:

    /usr/bin/python2.6 setup.py build_ext -i

See the documentation for alternative ways of installing the program.

The original error message follows.

Traceback (most recent call last):
  File "./bin/cutadapt", line 9, in <module>
    from cutadapt.scripts import cutadapt
  File "/user/cutadapt-1.9.1/cutadapt/scripts/cutadapt.py", line 62, in <module>
    check_importability()
  File "/user/cutadapt-1.9.1/cutadapt/__init__.py", line 9, in check_importability
    import cutadapt._align
ImportError: /user/cutadapt-1.9.1/cutadapt/_align.so: undefined symbol: PyFPE_jbuf

I get the same error even after running

[user@user cutadapt-1.9.1]$ python setup.py build_ext -i

After running the above command as mentioned in the manual I get

[user@user cutadapt-1.9.1]$ python setup.py build_ext -i
running build_ext

The python version is 2.6...

Can some one tell me whats going wrong..

Thanks..

Regards
Vishwesh

cutadapt tool next-gen • 1.6k views
ADD COMMENTlink modified 12 weeks ago by RamRS19k • written 2.8 years ago by vishweshwaransridhar10

Did you try to install it via a package manager (eg pip install --upgrade cutadapt)?

ADD REPLYlink modified 12 weeks ago by RamRS19k • written 2.8 years ago by Dan D6.6k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1047 users visited in the last hour