Trouble installing VEP
1
1
Entering edit mode
6.4 years ago
John ▴ 160

Dear all, I would like to install on my Ubuntu 14.04 Variant Effect Predictor and I have still trouble during installation. Very interesting is that I have vep installed on the same linux distribution with no troubles (biolinux).

After perl INSTALL.pl

I have message:

Created MYMETA.yml and MYMETA.json
Creating new 'Build' script for 'Bio-DB-HTS' version '1.11'
Module::Build version 0.42 required--this is only version 0.4003 at ./Build line 41.
ERROR: Shared Bio::DB:HTS library not found

After trying install separetly Bio-HTS I have error:

> *** Building Bio::DB::HTSlib *** Created MYMETA.yml and MYMETA.json Creating new 'Build' script for 'Bio-DB-HTS' version '1.11'
> Module::Build version 0.42 required--this is only version 0.4003 at
> ./Build line 41. Module::Build version 0.42 required--this is only
> version 0.4003 at ./Build line 41. Build test failed. Not continuing
> at INSTALL.pl line 115. cannot remove path when cwd is
> /tmp/WCNpSQrdt4/Bio-HTS for /tmp/WCNpSQrdt4:  at
> /usr/share/perl/5.18/File/Temp.pm line 921.

Please do you have any idea how to avoid this error mesages?

Thank you so much.

vep perl • 8.0k views
ADD COMMENT
1
Entering edit mode

error message says your Module::Build version is 0.4003 and you should upgrade it to 0.42

see this link

ADD REPLY
7
Entering edit mode
5.8 years ago
John ▴ 160

Very easy fix is:

sudo perl INSTALL.pl --NO_HTSLIB

ADD COMMENT

Login before adding your answer.

Traffic: 1212 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6