myrast runtime error
2
1
Entering edit mode
6.6 years ago
Enka ▴ 10

Hello.

I am trying to install the RAST client in biolinux but when I try to open the deb file myrast-runtime_1.0-1ubuntu1_amd64.deb it tells me that it couldn't resolve the dependency to libdb4.8. Previously I typed

apt-get install blast2 libwxgtk2.8-0 libdb4.8 libxml2

as read in the RAST site.

How can I solve this?

Thanks.

rast biolinux • 1.7k views
ADD COMMENT
0
Entering edit mode

I am having the same issue.

ADD REPLY
1
Entering edit mode
6.5 years ago
jfkell05 ▴ 10

I figured out the problem ( I think ) and got myrast to install:

Visit this site: http://www.ubuntuupdates.org/package/core/precise/main/base/libdb4.8

Under "Download "libdb4.8"" - I clicked the "64 bit deb package"

On my computer, everything is downloaded to the ~/Downloads folder. To install type:

$ sudo dpkg -i ~/Downloads/libdb4.8_4.8.30-11ubuntu1_amd64.deb

Then you can install myrast

$ sudo dpkg -i ~/Downloads/myrast-runtime_1.0-1ubuntu1_amd64.deb

$ sudo dpkg -i ~/Downloads/myrast_33-1ubuntu2_amd64.deb

ADD COMMENT
0
Entering edit mode
5.0 years ago
ropolocan ▴ 760

Depending on the system, you might also find that, besides lidb4.8, you need libwxgtk2.8-0. I could not find this on the repos, so I downloaded by following the instructions found here.

Those instructions are:

1. Add the following line to /etc/apt/sources.list:

# deb http://www.deb-multimedia.org jessie main

2. Update the package index:

# sudo apt-get update

3. Install GPG key of the repository:

# sudo apt-get install deb-multimedia-keyring

4. Install libwxgtk2.8-0 deb package:

# sudo apt-get install libwxgtk2.8-0
ADD COMMENT

Login before adding your answer.

Traffic: 1019 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6