Error: segment-based junction search failed with err =-5
3
3
Entering edit mode
6.0 years ago
ihabyounis ▴ 30

Hello, I am new to using tophat and bowtie for RNA-seq data. I am using MAC OSX10.11.4. I downloaded and unpacked the tophat2 binaries (ophat-2.1.1.OSX_x86_64). I also downloaded Bowtie2-2.2.9. I ran the test on the folder that is on tophat website (test_data) and I am getting the following error

dyn-172-20-71-206:test_data iyounis$ tophat2 -r 20 test_ref reads_1.fq reads_2.fq

[2016-05-11 11:37:54] Beginning TopHat run (v2.1.1)
-----------------------------------------------
[2016-05-11 11:37:54] Checking for Bowtie
          Bowtie version:    2.2.9.0
[2016-05-11 11:37:54] Checking for Bowtie index files (genome)..
    Found both Bowtie1 and Bowtie2 indexes.
[2016-05-11 11:37:54] Checking for reference FASTA file
[2016-05-11 11:37:54] Generating SAM header for test_ref
[2016-05-11 11:37:54] Preparing reads
     left reads: min. length=75, max. length=75, 100 kept reads (0 discarded)
    right reads: min. length=75, max. length=75, 100 kept reads (0 discarded)
[2016-05-11 11:37:54] Mapping left_kept_reads to genome test_ref with Bowtie2 
[2016-05-11 11:37:54] Mapping left_kept_reads_seg1 to genome test_ref with Bowtie2 (1/3)
[2016-05-11 11:37:54] Mapping left_kept_reads_seg2 to genome test_ref with Bowtie2 (2/3)
[2016-05-11 11:37:55] Mapping left_kept_reads_seg3 to genome test_ref with Bowtie2 (3/3)
[2016-05-11 11:37:55] Mapping right_kept_reads to genome test_ref with Bowtie2 
[2016-05-11 11:37:55] Mapping right_kept_reads_seg1 to genome test_ref with Bowtie2 (1/3)
[2016-05-11 11:37:55] Mapping right_kept_reads_seg2 to genome test_ref with Bowtie2 (2/3)
[2016-05-11 11:37:55] Mapping right_kept_reads_seg3 to genome test_ref with Bowtie2 (3/3)
[2016-05-11 11:37:55] Searching for junctions via segment mapping
    [FAILED]
Error: segment-based junction search failed with err =-5
  Reason: image not found

I checked the segment_juncs.log file and it reads the following:

dyld: Library not loaded: /usr/local/opt/boost/lib/libboost_thread-mt.dylib
  Referenced from: /Users/iyounis/Desktop/RNA_seq_analysis/tophat-2.1.1.OSX_x86_64/segment_juncs
  Reason: image not found

I downloaded tophat binaries because I didn't want to mess with boost, but I am not sure what to do next

Any help?

RNA-Seq tophat bowtie2 • 4.7k views
ADD COMMENT
0
Entering edit mode

Shoot the tophat authors an email and let them know that they have a wrong library getting linked in.

ADD REPLY
0
Entering edit mode

I'm having this same problem now. Any resolution?

ADD REPLY
0
Entering edit mode

This problem still exists as of today; I got the same error.

ADD REPLY
0
Entering edit mode

I have the exact same issue. Has anybody been able to resolve this problem?

ADD REPLY
3
Entering edit mode
5.9 years ago

I've ran into similar issues with tophat 2.1.1. I installed version 2.0.13 (that I had used on an older computer) and that still works fine for me, so something is probably up with tophat 2.1.1 (but I don't know what).

ADD COMMENT
0
Entering edit mode

Thanks. I got the same situation and solved with the same way.

ADD REPLY
0
Entering edit mode

Thanks, I can confirm presently a similar approach works with the version after 2.0.13.
2.0.14 works as well when you get that error Error: segment-based junction search failed with err =-5 using 2.1.1 on a Mac computer.
Here is how I did the installation of 2.0.14. I don't know if the tbb threaded boost library is necessary for this version, and so if you have wget already you may choose to start with the third line and forget any use of Homebrew.

brew install wget
brew install tbb
cd /usr/local/bin/
sudo wget http://ccb.jhu.edu/software/tophat/downloads/tophat-2.0.14.OSX_x86_64.tar.gz
sudo tar zxvf tophat-2.0.14.OSX_x86_64.tar.gz
sudo rm -f tophat-2.0.14.OSX_x86_64.tar.gz
cd /usr/local/bin/tophat-2.0.14.OSX_x86_64/
sudo rm AUTHORS
sudo rm COPYING
sudo rm README
cd /usr/local/bin/
sudo mv /usr/local/bin/tophat-2.0.14.OSX_x86_64/* /usr/local/bin
sudo rm -rf /usr/local/bin/tophat-2.0.14.OSX_x86_64

Also in regards to the original poster, you can run into trouble using the later Bowtie2 versions since that software has continued to be developed while Tophat2 is in a maintenance mode. I made a table of Tophat2 and Bowtie2 compatibility to make it easier to track.

ADD REPLY
2
Entering edit mode
4.7 years ago

I fixed this error by installing the boost library. On MacOS via Homebrew, this was as easy as brew install boost .

(The hint was that it was complaining about not loading a boost library here ( dyld: Library not loaded: /usr/local/opt/boost/lib/libboost_thread-mt.dylib)).

ADD COMMENT
0
Entering edit mode
5.7 years ago

TOPHAT v2.1.1 gave the same error reported above "Error: segment-based junction search failed with err =-5 Reason: image not found"

can you kindly help me in sorting out this ?

ADD COMMENT

Login before adding your answer.

Traffic: 1090 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6