Error in building cufflinks
2
0
Entering edit mode
5.5 years ago
AHW ▴ 50

I am trying to building cufflinks from the source. I installed boost, samtools, Eigen repo and then after I tried to build cufflinks.

On trying

./configure --prefix=/home/hussain/cufflinks-2.2.1  --with-boost=/usr/include/boost --with-bam=/home/hussain/samtools-0.1.19

i get the following messages and eventually leads to error

checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking for gawk... (cached) mawk
checking for g++... g++
checking for C++ compiler default output file name... a.out
checking whether the C++ compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for style of include used by make... GNU
checking dependency style of g++... gcc3
checking for gcc... gcc
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... gcc3
checking whether make sets $(MAKE)... (cached) yes
checking for ranlib... ranlib
checking for a BSD-compatible install... /usr/bin/install -c
checking for a Python interpreter with version >= 2.4... python
checking for python... /usr/bin/python
checking for python version... 2.7
checking for python platform... linux2
checking for python script directory... ${prefix}/lib/python2.7/site-packages
checking for python extension module directory... ${exec_prefix}/lib/python2.7/site-packages
checking for boostlib >= 1.47.0... yes

checking for bamlib... configure: error: We could not detect the bam libraries (version or higher). If you have a staged bam library (still not installed) please specify $BAM_ROOT in your environment and do not give a PATH to --with-bam option. If you are sure you have bam installed, then check your version number looking in <bam version.hpp="">. See http://randspringer.de/bam for more documentation. hussain@hussain-WIV68B55-0346:~/cufflinks-2.2.1$

Its very hectic and frustrating to get this error after trying to set path variables and other options. What is going wrong.

cufflink • 2.6k views
ADD COMMENT
0
Entering edit mode
4.9 years ago
Sanjiv Kumar ▴ 20

Someone in one of the google groups wrote this " rename version.p to version.hpp. This file is located in your samtools folder try to find version.p in /usr/local/include/bam and rename it to version.hpp" This method worked for me too.

ADD COMMENT
1
Entering edit mode

Frustratingly, now, it is sudo cp /usr/local/include/bam/version.h /usr/local/include/bam/version.hpp

ADD REPLY
0
Entering edit mode
4.9 years ago
Sanjiv Kumar ▴ 20

Use http://cole-trapnell-lab.github.io/cufflinks/install/ to download pre-compiled library for your OS, to get working, while you try to solve building from source. I had tough time too building it from the source.

ADD COMMENT

Login before adding your answer.

Traffic: 1870 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6