ShapeIt giving Segfault 11?
1
1
Entering edit mode
6.2 years ago
jwhite ▴ 10

Hi all,

I'm trying to successfully run SHAPEIT to phase haplotypes but am not having luck. (https://mathgen.stats.ox.ac.uk/genetics_software/shapeit/shapeit.html).

I'm running El Capitan and have downloaded the Mac option from the SHAPEIT webpage. I've recently installed Boost libraries using

brew install boost

Then, I navigated both the SHAPEIT exe file and the following example files into a new folder called "Test". So the Test folder has: genetic_map.txt, gwas.bed, gwas.bim, gwas.fam, and shapeit

The code I'm trying to run is from the "Getting Started" tab of the SHAPEIT website

./shapeit --input-bed gwas.bed gwas.bim gwas.fam \
          --input-map genetic_map.txt \
          --output-max gwas.phased.haps gwas.phased.sample ;

The problem is that I get the message:

Segmentation fault: 11

I've Googled, and as best I can figure out is that this problem results when a program tries to call memory that it's not allowed to call and usually you can fix it by going into the code directly to change settings. It seems like it's an error that developers usually run into. Since I don't have the code for SHAPEIT and I'm a coding novice, I'm at a loss for what to do next. I've tried the same piece of code on another Mac running Mavericks and the same error resulted.

Has anyone else run into this issue? Does anyone have suggestions?

Thanks!

software error • 2.4k views
ADD COMMENT
0
Entering edit mode

The latest Mac download at the site you linked is for v. 10.9.x. You are assuming that it will actually work on the latest Mac OS. I suggest that you email the authors and ask about compatibility.

ADD REPLY
0
Entering edit mode

I thought compatibility might be the issue as well, so I tried the same piece of code on another (bigger) Mac that is running 10.9 and got the same error.

ADD REPLY
0
Entering edit mode

I'm trying to install SHAPEIT4 without any success on macOS Mojave...

ADD REPLY
0
Entering edit mode
6.2 years ago
cae803 • 0

I had the same trouble. So I am using the earlier version of SHAPEIT.v2.r790 here. I referred a post of the OXSTATGEN mailing list.

ADD COMMENT

Login before adding your answer.

Traffic: 2158 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6