Question: topgo rnaseq error
0
gravatar for tarek.mohamed
4.1 years ago by
tarek.mohamed270
tarek.mohamed270 wrote:

Hi,

I am trying to use topgo to do GO analysis for a RNA-seq data I have analyzed using DESeq2.

I got this error

Error in if is.na(index) || index < 0 || index > length(nd)) stop("vertex is not in graph: ", : missing value where TRUE/FALSE needed

Here is my script

>biocLite("topGO")
>library(topGO)

>library(org.Hs.eg.db)

>all <- res$padj

>names(all) <- rownames(res)
>all <- na.omit(all)
>head(all)
>names(all)
>str(res$padj)
>head(res)
>GOdata <- new("topGOdata",ontology = "CC", allGenes = all, geneSel=function(p) p < 0.01, description ="CardiomyocytesGenes", annot=annFUN.org, mapping="org.Hs.eg.db", ID="Ensembl") 

Building most specific GOs .....

    ( 0 GO terms found. )

Build GO DAG topology ..........
    ( 0 GO terms and 0 relations. )
Error in if is.na(index) || index < 0 || index > length(nd)) stop("vertex is not in graph: ",  : 
  missing value where TRUE/FALSE needed
rna-seq topgo • 1.6k views
ADD COMMENTlink modified 4.1 years ago by genomax89k • written 4.1 years ago by tarek.mohamed270
1

Hi ,

I knew what was the mistake.

I have added gene names instead of ensembl gene id to my results, that is why the mapping did not work.

Thanks

Tarek

ADD REPLYlink written 4.1 years ago by tarek.mohamed270
0
gravatar for tarek.mohamed
4.1 years ago by
tarek.mohamed270
tarek.mohamed270 wrote:

Hi ,

I knew what was the mistake.

I have added gene names instead of ensembl gene id to my results, that is why the mapping did not work.

Thanks

Tarek

ADD COMMENTlink written 4.1 years ago by tarek.mohamed270
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 726 users visited in the last hour