cannot clone submodules of Proovread program
1
0
Entering edit mode
5.4 years ago
xiachongjing ▴ 10

Hello everyone:

I got problem when I was trying to git clone some submodules, even though I used --recursive. The thing is I can git clone the repository successfully. The command I used was:

git clone --recursive git://github.com/BioInf-Wuerzburg/proovread

I got log like this:

Cloning into 'proovread'...

remote: Counting objects: 2034, done.

remote: Total 2034 (delta 0), reused 0 (delta 0), pack-reused 2034

Receiving objects: 100% (2034/2034), 9.20 MiB | 4.58 MiB/s, done.

Resolving deltas: 100% (1276/1276), done.

Checking connectivity... done.

Checking out files: 100% (57/57), done.

Submodule 'util/SeqChunker' (https://github.com/BioInf-Wuerzburg/SeqChunker.git) registered for path 'util/SeqChunker'

Submodule 'util/SeqFilter' (https://github.com/BioInf-Wuerzburg/SeqFilter.git) registered for path 'util/SeqFilter'

Submodule 'util/bwa' (https://github.com/BioInf-Wuerzburg/bwa.git) registered for path 'util/bwa'

Cloning into 'util/SeqChunker'...

fatal: unable to access 'https://github.com/BioInf-Wuerzburg/SeqChunker.git/': SSL connection timeout

Clone of 'https://github.com/BioInf-Wuerzburg/SeqChunker.git' into submodule path 'util/SeqChunker' failed

However, it'll work if I clone each submodules seperately, e.g.: git clone git://github.com/BioInf-Wuerzburg/SeqChunker.git .(it won't if I use git clone https://github.com/BioInf-Wuerzburg/SeqChunker.git)

Any help is highly appreciated. Thanks.

software error next-gen • 1.4k views
ADD COMMENT
0
Entering edit mode

This was either a transitory error or something specific to your local conditions. The cloning is working for me.

ADD REPLY
0
Entering edit mode

Thanks. Then do you have any ideas to solve this, assuming there is a transitory error or my local conditions ? Thanks.

ADD REPLY
0
Entering edit mode

Is it still not working for you?

ADD REPLY
0
Entering edit mode

No, still not working. I guess there is something wrong with the submodule part. I can clone each submodule successfuly with code:

git clone git://github.com/BioInf-Wuerzburg/SeqChunker.git

So now I am thinking probably I can try to turn https: into git: for each submodule when doing <git clone="" --recursive="">. Something like this:http://stackoverflow.com/questions/4891527/git-protocol-blocked-by-company-how-can-i-get-around-that

So what's your idea? Thanks

ADD REPLY
0
Entering edit mode
5.4 years ago
xiachongjing ▴ 10

Finally, I got this issue solved. Basically, for some reason in my system the <git clone=""> cannot clone repository from https://, but it can clone repository from git://. So my solution is to tell <git clone=""> to change https:// to git://. And it works for me. The code I used for program Proovread v2.13.13 was:

git config --global url."git://github".insteadOf https://github

git clone --recursive git://github.com/BioInf-Wuerzburg/proovread

I got the idea from this http://stackoverflow.com/questions/4891527/git-protocol-blocked-by-company-how-can-i-get-around-that

ADD COMMENT

Login before adding your answer.

Traffic: 1928 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6