Question: Affymetrix Power Tools Error #2
0
gravatar for Steve
3.5 years ago by
Steve10
Steve10 wrote:

I have been trying to filter microarray data by using affymetrix power tools. I have been coming across obstacles and now I have an error for reading the cdf. My input was ->

apt-probeset-summarize -a rma -d MoGene-1_0-st-v1.r3.cdf -o output /home/ubuntu/GSM538415_EA07068_52753_MoGene_T.8Nve.Sp_1.CEL

And it gives me the error ->

FATAL ERROR:EngineUtil::getCdfChipType() - Can't read header for 'MoGene-1_0-st-v1.r3.cdf'. Description: Unable to open the file.

What does this mean? Would anyone be able to help me?

ADD COMMENTlink modified 3.5 years ago by genomax78k • written 3.5 years ago by Steve10

This appears to be a similar problem like the one in your last post. You need to provide the full path to the cdf file and make sure it is readable by everyone by doing a chmod a+r MoGene-1_0-st-v1.r3.cdf.

I am going to echo @Wouter and say that it would help you immensely if you spend half a day learning the basics of unix command line here.

ADD REPLYlink modified 3.5 years ago • written 3.5 years ago by genomax78k

When I do -> chmod a+r MoGene-1_0-st-v1.r3.cdf

Output is -> chmod: cannot access 'MoGene-1_0-st-v1.r3.cdf': No such file or directory

I want to ask, if I am running Linux ubuntu off a live usb, would that have any effect to why it doesnt want to read?

ADD REPLYlink modified 3.5 years ago • written 3.5 years ago by Steve10

You need to issue that command in the directory where that file is present or provide full path to the file if it is in another directory.

Glad you mentioned that you are using ubuntu off live USB. That is probably not a good way of trying to do this analysis. It may be better if you use a virtual machine (I assume you are on windows?).

ADD REPLYlink modified 3.5 years ago • written 3.5 years ago by genomax78k

When I type in the full path to the file and run the chmod a+r command, it gives me no output. It just goes to a new line. Is this what I should be expecting when I type in the command

ADD REPLYlink written 3.5 years ago by Steve10

what does ls -lh /path_to/MoGene-1_0-st-v1.r3.cdf show?

ADD REPLYlink written 3.5 years ago by genomax78k

It says -> cannot access: (path to file): No such file in directory

I will say this, I have used this file in another computer and it has seemed to recognize it. Unfortunately, APT software does not run on the OS of the mac I have. Now I am beginning to think that it is because I am running off a live usb for ubuntu.

ADD REPLYlink modified 3.5 years ago • written 3.5 years ago by Steve10

APT installer for Mac says "yosemite". What OS X are you using? I assume you have already tried to use the binary provided? Did that not work?

If you are brave you can always download the source and try to compile the program yourself (but do that only if the above does not work).

ADD REPLYlink written 3.5 years ago by genomax78k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1300 users visited in the last hour