Question: Question about install Tophat and Cufflinks (Boost issue)
0
gravatar for Joe
10 months ago by
Joe20
USA
Joe20 wrote:

I'm using Ubuntu 1604 in Oracle VM VirtualBox. Try to follow http://staff.um.edu.mt/jebej02/blog/2016/05/23/installing-cufflinks-rnaseq-on-ubuntu/ to install Cufflinks in Ubuntu. But have issue when I install Tophat:

$ tar xzvf tophat-2.1.1.tar.gz

$ cd tophat-2.1.1

$ ./configure --prefix /opt/tophat-2.1.1 --with-boost=/opt/boost_1_61_0

after I type "./configure --prefix /opt/tophat-2.1.1 --with-boost=/opt/boost_1_61_0", I see

checking for boostlib >= 1.38.0... configure: error: We could not detect the boost libraries (version 1.38 or higher). If you have a staged boost library (still not installed) please specify $BOOST_ROOT in your environment and do not give a PATH to --with-boost option. If you are sure you have boost installed, then check your version number looking in <boost version.hpp="">. See http://randspringer.de/boost for more documentation.

Then I type

dpkg -s libboost-dev | grep 'Version'

Version: 1.58.0.1ubuntu1

**Why the version is still 1.58 but not 1.61?

**How do I know I already successfully install boost 1.61?

How to solve "configure: error: We could not detect the boost libraries (version 1.38 or higher)." problem? Thanks!!**

boost cufflinks tophat • 483 views
ADD COMMENTlink modified 3 months ago • written 10 months ago by Joe20
1

Is there a reason not to use the pre-compiled tophat linux binary? That should avoid all these issues.

ADD REPLYlink written 10 months ago by genomax29k

I know I can use "apt-get" to install Tophat directly.

But the goal is install Cufflinks, to follow the http://staff.um.edu.mt/jebej02/blog/2016/05/23/installing-cufflinks-rnaseq-on-ubuntu/ step by step, I'm not sure if I skip Tophat in the link will cause problem.

ADD REPLYlink written 10 months ago by Joe20

There is no guarantee that apt-get will install the latest binaries. You can adjust $PATH once you download the pre-compiled binaries.

Even for cufflinks you can get a pre-compiled linux binary here.

ADD REPLYlink modified 10 months ago • written 10 months ago by genomax29k

I need to install boost 1.61, do I need to completely remove boost 1.58 to make 1.61 work?

ADD REPLYlink written 10 months ago by Joe20

You don't need to install or uninstall either of them. Ignore the instructions you found on that blog. Download this, extract it, move the executables to somewhere in your path and you're done. Why the person who wrote that blog wasted so much time is beyond me.

ADD REPLYlink written 10 months ago by Devon Ryan68k

lol, I gonna try it soon.

ADD REPLYlink written 10 months ago by Joe20

I downloaded cufflink from this link as you mention above: :http://cole-trapnell lab.github.io/cufflinks/assets/downloads/cufflinks-2.2.1.Linux_x86_64.tar.gz

But when I am running cammand: /home/yog/software/cufflinks-2.2.1.Linux_x86_64/gffread

it do not run.

ADD REPLYlink written 5 months ago by nabiyogesh60
1
gravatar for Joe
3 months ago by
Joe20
USA
Joe20 wrote:

I figure it out by myself, use Ubuntu 1404x instead of 1604 to avoid all these issues. I'm using 14045 right now.

ADD COMMENTlink written 3 months ago by Joe20
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1150 users visited in the last hour