Question: gemini query error
0
gravatar for krismopolitan
3.1 years ago by
krismopolitan0 wrote:

Hi,

I'm trying to query a gemini database made from a merged vcf file and a ped file.

The vcf was made from WGS reads by using speedseq i.e. FreeBayes caller.

The PED file looks like this:

3 Sample_6-F3S4-77749 -9 -9 -9 ALL
3 Sample_7-F3S5-77750 -9 -9 -9 ALL

I have tried running several queries, but every single one gives me this error:

  File "/services/tools/anaconda2/4.0.0/bin/gemini", line 6, in <module>
    gemini.gemini_main.main()
  File "/services/tools/anaconda2/4.0.0/lib/python2.7/site-packages/gemini/gemini_main.py", line 1227, in main
    args.func(parser, args)
  File "/services/tools/anaconda2/4.0.0/lib/python2.7/site-packages/gemini/gemini_main.py", line 422, in query_fn
    gemini_query.query(parser, args)
  File "/services/tools/anaconda2/4.0.0/lib/python2.7/site-packages/gemini/gemini_query.py", line 167, in query
    run_query(args)
  File "/services/tools/anaconda2/4.0.0/lib/python2.7/site-packages/gemini/gemini_query.py", line 122, in run_query
    subjects = get_subjects(args)
  File "/services/tools/anaconda2/4.0.0/lib/python2.7/site-packages/gemini/gemini_subjects.py", line 136, in get_subjects
    gq = GeminiQuery.GeminiQuery(args.db)
  File "/services/tools/anaconda2/4.0.0/lib/python2.7/site-packages/gemini/GeminiQuery.py", line 550, in __init__
    self.idx_to_sample_object = {s['sample_id'] -1: Subject(s) for s in samples}
  File "/services/tools/anaconda2/4.0.0/lib/python2.7/site-packages/gemini/GeminiQuery.py", line 550, in <dictcomp>
    self.idx_to_sample_object = {s['sample_id'] -1: Subject(s) for s in samples}
  File "/services/tools/anaconda2/4.0.0/lib/python2.7/site-packages/gemini/gemini_subjects.py", line 63, in __init__
    self._set_fields_from_row(row)
  File "/services/tools/anaconda2/4.0.0/lib/python2.7/site-packages/gemini/gemini_subjects.py", line 79, in _set_fields_from_row
    self.phenotype = int(self.phenotype) if self._has_phenotype() else None
ValueError: invalid literal for int() with base 10: 'ALL'

Anyone have an idea of how to fix this?

Thank you,

query error sql wgs gemini • 941 views
ADD COMMENTlink modified 3.1 years ago • written 3.1 years ago by krismopolitan0
1
gravatar for krismopolitan
3.1 years ago by
krismopolitan0 wrote:

HI again,

Just in case anyone with a similar problem stumbles upon this thread; I managed to run without problems simply by not specifying the phenotype, i.e. changed the .ped file to

3 Sample_6-F3S4-77749 -9 -9 -9 -9
3 Sample_7-F3S5-77750 -9 -9 -9 -9

and reloaded the gemini database.

Bw.

ADD COMMENTlink written 3.1 years ago by krismopolitan0
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 2620 users visited in the last hour