Question: Picard install problem
0
gravatar for agicict
2.5 years ago by
agicict140
Korea, Republic Of
agicict140 wrote:

Hello.

I am trying to install picard-1.73 because of some reasons.

I downloaded picard 1.73 from sourceforge and unzipped it.

However, I cannot execute following command.

java -jar picard-1.73.jar -h

Error message is

Failed to load Main-Class manifest attribute from

picard-1.73.jar

I changed java version from 6 to 9 but all failed.

What should I do to run it?

install picard • 1.4k views
ADD COMMENTlink modified 2.5 years ago by Pierre Lindenbaum122k • written 2.5 years ago by agicict140
3
gravatar for Pierre Lindenbaum
2.5 years ago by
France/Nantes/Institut du Thorax - INSERM UMR1087
Pierre Lindenbaum122k wrote:

I am trying to install picard-1.73

picard-1.73 ? sourceforge is deprecated for picard. download the latest version 2.9.0 : https://github.com/broadinstitute/picard/releases/tag/2.9.0

Failed to load Main-Class manifest attribute from

because as far as I remember in the old version of picard, 'picard.jar' was just the library. The main classes where splitted in their own *.jar

e.g: java -cp a.jar:b:jar:c.jar:MarkDuplicate.jar -h

don't do this with picard 2.9;0

java -jar picard.jar -h

I changed java version from 6 to 9 but all failed.

java 8 is required

ADD COMMENTlink modified 2.5 years ago • written 2.5 years ago by Pierre Lindenbaum122k

Really helpful comment! Thank you.

ADD REPLYlink written 2.5 years ago by agicict140
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1670 users visited in the last hour