Updated R version to 3.3.3 and now I can not download from source("http://bioconductor.org/biocLite.R")
0
1
Entering edit mode
7.0 years ago
yzfmonster ▴ 20

Dear experts!

I had no problem downloading the following packages when I had version 3.0.7 last weekend, but I upgraded to 3.3.3 now.

source("http://bioconductor.org/biocLite.R")
biocLite("DESeq2")
source("http://bioconductor.org/biocLite.R")
biocLite("edgeR")
source("http://bioconductor.org/biocLite.R")
biocLite("limma")
source("http://bioconductor.org/biocLite.R")
biocLite("Biobase")

and now I can not download the same things. Any help appreciated! Many thanx

yzf

OK it seems that the problem is bioconductor version so I tried to install bioconductor by

source("https://bioconductor.org/biocLite.R")
biocLite()

But this is what I get.

'biocLite.R' failed to install 'BiocInstaller', use 'install.packages("BiocInstaller",
  repos="https://bioconductor.org/packages/3.4/bioc")' or 'install.packages("BiocInstaller", repos="http://bioconductor.org/packages/3.4/bioc")'
RNA-Seq • 5.4k views
ADD COMMENT
0
Entering edit mode

What is the error you get when you try to install the package.

ADD REPLY
0
Entering edit mode

Thanks for reply. I get many warnings and error message.

'biocLite.R' failed to install 'BiocInstaller', use 'install.packages("BiocInstaller", repos="https://bioconductor.org/packages/3.4/bioc")' or 'install.packages("BiocInstaller", repos="http://bioconductor.org/packages/3.4/bioc")'

ADD REPLY
1
Entering edit mode

Problem solved by

install.packages("BiocInstaller",repos="http://bioconductor.org/packages/3.4/bioc")
ADD REPLY
0
Entering edit mode

Thanks for posting your own solution to follow up!

ADD REPLY
0
Entering edit mode

You may have installed R without support for https. How did you update it? Which operating system?

ADD REPLY
0
Entering edit mode

I still have to remove s from https. Thank you

ADD REPLY
0
Entering edit mode

If the same command does not work with https and work with http, then it is that you didn't install with support for https. I could help you more if you explained how you installed R and which operating system.

ADD REPLY
0
Entering edit mode

I modified your post with code formatting for readability. You can do the same, by just selecting the text you want to format and clicking on the 101010 button. Please take this into account for your posts in the future.

ADD REPLY
0
Entering edit mode

Thank you for fixing my messages. Could you please explain what/where 101010 button is? Thank you again.

ADD REPLY
0
Entering edit mode

When you compose or edit a post it's in your toolbar, see image below:

101010 Button

ADD REPLY

Login before adding your answer.

Traffic: 1471 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6