Question: how to use build.mim function and on what type of data?
1
gravatar for mona
22 months ago by
mona10
india
mona10 wrote:

how to solve the error of :"Error in cor(dataset, method = estimator, use = "complete.obs") : no complete element pairs" befor using build.mim function in minet package

R • 687 views
ADD COMMENTlink written 22 months ago by mona10

please check; your genes should place in columns and samples in rows.

I think you read your original file with row.names = 1

simply read your file

then

mim <- build.mim(your.data,estimator="spearman")
ADD REPLYlink modified 22 months ago • written 22 months ago by F3.3k

the columns contain the genes and rows have the samples .and while reading my file I didn't use row.names=1

ADD REPLYlink written 22 months ago by mona10

I have been facing the same issue. Have you found any solution yet ? If so could you please share how you overcame this problem ?

ADD REPLYlink modified 11 months ago • written 11 months ago by akhilpotdar44050

In your original data generaly genes are in row and samples in columns, if so; read your file so

your.data=t(read.table("your.data.txt", header = T, sep = "\t",row.names = 1))

then

library(minet)

and

mim <- build.mim(your.data,estimator="spearman")
ADD REPLYlink written 11 months ago by F3.3k

Thank you for your reply.

your.data=t(read.table(file.choose(), header = T, sep = "\t",row.names = 1)) mim <- build.mim(your.data,estimator="spearman") Error in cor(dataset, method = estimator, use = "complete.obs") : no complete element pairs

i have been getting this error. whenever the gene list goes above 1000 . I have come to believe that this function is limited to a certain input range. I however want your outlook on this situation so that i can take a different route in my analysis.

my gene microarray dataset has 3264 genes across 6 timepoints

ADD REPLYlink written 11 months ago by akhilpotdar44050

Add use="complete.obs" to build.mim

ADD REPLYlink written 11 months ago by F3.3k

mim <- build.mim(genematrix,use="complete.obs") #Build Mutual Information Matrix Error in build.mim(genematrix, use = "complete.obs") : unused argument (use = "complete.obs")

This is the output after adding the parameter

ADD REPLYlink written 10 months ago by akhilpotdar44050
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1807 users visited in the last hour