Question: makeblastdb error: Error: (803.7) [makeblastdb] Blast-def-line-set.E.seqid.E.local.str Bad char [0xC3] in string at byte 45
0
gravatar for m.rhodes
2.6 years ago by
m.rhodes20
m.rhodes20 wrote:

I'm trying to make a blastdb out of fungal ITS sequences from UNITE (https://unite.ut.ee/index.php). I downloaded the general fasta file and edited the fasta headers so they look like this:

GQ280590|Calonectria_leucothoës

DQ675574|Epichloë_sibirici

e.t.c.

However, when I run this makeblastdb command:

./makeblastdb -in unite_fungi.fasta -out UNITE_ITS.fasta -dbtype nucl -parse_seqids

I am getting the following error for all entries:

Error: (803.7) [makeblastdb] Blast-def-line-set.E.seqid.E.local.str

Bad char [0xAB] in string at byte 46.

Initially I thought it could be something to do with tabs/spaces at the end of the header, so I tried removing them using (please correct me if I'm wrong):

sed 's/[[:blank:]]*$//'

However, this did not work either.

Does anyone know why this might be happening?

Thanks in advance.

blast ncbi makeblastdb • 1.9k views
ADD COMMENTlink modified 2.6 years ago by genomax75k • written 2.6 years ago by m.rhodes20

Wonder if the issue is using non-US character set.

ADD REPLYlink written 2.6 years ago by genomax75k

could you please elaborate?

ADD REPLYlink written 2.6 years ago by m.rhodes20
1

Do you know what unicode character set you are using on this machine? The error you have posted above seems to be referring to this character.

ADD REPLYlink written 2.6 years ago by genomax75k

No, but that link helped solve my problem! Turns out it was the 'ë' characters in the fasta headers that were causing the problem. Thanks for the help!

ADD REPLYlink written 2.6 years ago by m.rhodes20
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1794 users visited in the last hour