SCDE Package error
1
0
Entering edit mode
6.6 years ago
shg018 ▴ 10

Hi everyone

So I had a question about the scde package in R which I am trying to use for single cell analysis. When I try to run it in R using the code below: source("https://bioconductor.org/biocLite.R") biocLite("scde")

I get warning message: package 'scde' is not available (for R version 3.2.3)

and I essentially need to use the scde.error.models function using: o.ifm <- scde.error.models(counts = cd, groups = sg, n.cores = 10, threshold.segmentation = TRUE, save.crossfit.plots = FALSE, save.model.plots = FALSE, verbose = 1)

which as expected gives me the error that this function does not exist. My question is how can I get scde to work or if that is not possible, what should I be using instead?

R RNA-Seq • 1.6k views
ADD COMMENT
2
Entering edit mode
6.6 years ago
erictleung ▴ 110

According to the warning you're getting

package 'scde' is not available (for R version 3.2.3)

looks like you'll want to upgrade your R version. Currently, R is at 3.4.1. I'd upgrade R and Bioconductor both to see if that fixes your problem. Good luck.

ADD COMMENT
0
Entering edit mode

Thank you soo much!! That worked!

If you don't mind me asking, when I run:

o.ifm <- scde.error.models(counts = cd, groups = sg, n.cores = 10, threshold.segmentation = TRUE, save.crossfit.plots = FALSE, save.model.plots = FALSE, verbose = 1)

I am getting the error that arguments must have same length and error in tapply(...){. Which arguments does it refer to?

ADD REPLY
1
Entering edit mode

I haven't used scde.error.models() before, but I would guess it has to do with the counts or groups parameters. According to the documentation, counts should be

a read count matrix...the rows correspond to genes (should be named), columns correspond to individual cells.

So I would check if the columns of cd match what you've input as sg.

ADD REPLY

Login before adding your answer.

Traffic: 1250 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6