Question: igv_plotter error, I cannot run igv_plotter on my BAM file, RuntimeError: Xvfb did not start
0
gravatar for cristian
11 months ago by
cristian90
cristian90 wrote:

Hi there,

I have installed igv_plotter with

sudo pip install igv_plotter

and

checked it with

igv_plotter 

igv_plotter
usage: igv_plotter [-h] [-o OUTPUT] [-L LOCUS_FILE] [-v] [--width WIDTH]
                   [--height HEIGHT] [--max-panel-height MAX_PANEL_HEIGHT]
                   [-c CONFIG_FILE] [-m MAX_MEMORY] [-g GENOME] [-p KEY=VALUE]
                   [--view-as-pairs] [--igv-jar-path IGV_JAR_PATH]
                   [--expand | --squish | --collapse]
                   files or loci [files or loci ...]
igv_plotter: error: too few arguments

but when I run it with my bam file, it does not work and gives me an error:

igv_plotter -g output/genome/celegans/ref/seq/celegans.fa output/alignment/celegans/ref/illumina/star/raw/saltlakecity1a/saltlakecity1aAligned.sortedByCoord.out.bam I:12345

Traceback (most recent call last):
  File "/Users/cr517/anaconda/envs/python2env/bin/igv_plotter", line 140, in <module>
    igv_robot.execute()
  File "/Users/cr517/anaconda/envs/python2env/lib/python2.7/site-packages/igv_api.py", line 256, in execute
    self._execute_impl(self.__command_queue)
  File "/Users/cr517/anaconda/envs/python2env/lib/python2.7/site-packages/igv_api.py", line 387, in _execute_impl
    fake_display.start()
  File "/Users/cr517/anaconda/envs/python2env/lib/python2.7/site-packages/xvfbwrapper.py", line 79, in start
    raise RuntimeError('Xvfb did not start')
RuntimeError: Xvfb did not start

Can anybody explain why this is happening, please?

Thanks, Best, C.

ADD COMMENTlink modified 11 months ago • written 11 months ago by cristian90

Which operating system are you using? Did you log in using ssh -X (Unix)?

ADD REPLYlink modified 11 months ago • written 11 months ago by WouterDeCoster29k

Hi, I am using MacOS X. 10.12.5 Sierra. I am running it locally, so no ssh. What is the -X for?

ADD REPLYlink written 11 months ago by cristian90
1

That would be to enable X11 forwarding for graphical applications.

ADD REPLYlink written 11 months ago by WouterDeCoster29k

Thanks. Otherwise, any ideas about this RuntimeError? Do you know what Xvfb is?

ADD REPLYlink written 11 months ago by cristian90

We'll just have to wait for someone who knows more about MacOS X :-)

ADD REPLYlink written 11 months ago by WouterDeCoster29k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 921 users visited in the last hour