findGenomeMotif.pl in Homer couldn't work properly
2
1
Entering edit mode
6.5 years ago
xuenjun1 ▴ 10
./Homer/bin/findMotifsGenome.pl myc1_vs_input1.txt tair10 motif_based_on_myc1_vs_input1_cleaned_peaks/ -size 200 -mask

Position file = myc1_vs_input1.txt
Genome = tair10
Output Directory = motif_based_on_myc1_vs_input1_cleaned_peaks/
Fragment size set to 200
Will use repeat masked sequences
Found mset for "arabidopsis", will check against plants motifs
Peak/BED file conversion summary:
    BED/Header formatted lines: 0
    peakfile formatted lines: 4467

Peak File Statistics:
    Total Peaks: 4467
    Redundant Peak IDs: 0
    Peaks lacking information: 0 (need at least 5 columns per peak)
    Peaks with misformatted coordinates: 0 (should be integer)
    Peaks with misformatted strand: 0 (should be either +/- or 0/1)

Peak file looks good!

Background files for 200 bp fragments found.

Extracting sequences from file: /Users/xuenjun/Documents/CHIP-seq/Homer/.//data/genomes/tair10///genome.fa
Looking for peak sequences in a single file (/Users/xuenjun/Documents/CHIP-seq/Homer/.//data/genomes/tair10///genome.fa)

Not removing redundant sequences


Sequences processed:
    0 total

Frequency Bins: 0.2 0.25 0.3 0.35 0.4 0.45 0.5 0.6 0.7 0.8
Freq    Bin Count

Total sequences set to 50000

Choosing background that matches in CpG/GC content...

Illegal division by zero at /Users/xuenjun/Documents/CHIP-seq/Homer/bin/assignGeneWeights.pl line 63. Assembling sequence file... Normalizing lower order oligos using homer2

Reading input files...
0 total sequences read
Autonormalization: 1-mers (4 total)
    A   inf%    inf%    nan
    C   inf%    inf%    nan
    G   inf%    inf%    nan
    T   inf%    inf%    nan
Autonormalization: 2-mers (16 total)
    AA  inf%    inf%    nan
    CA  inf%    inf%    nan
    GA  inf%    inf%    nan
    TA  inf%    inf%    nan
    AC  inf%    inf%    nan
    CC  inf%    inf%    nan
    GC  inf%    inf%    nan
    TC  inf%    inf%    nan
    AG  inf%    inf%    nan
    CG  inf%    inf%    nan
    GG  inf%    inf%    nan
    TG  inf%    inf%    nan
    AT  inf%    inf%    nan
    CT  inf%    inf%    nan
    GT  inf%    inf%    nan
    TT  inf%    inf%    nan
Autonormalization: 3-mers (64 total)
Normalization weights can be found in file: motif_based_on_myc1_vs_input1_cleaned_peaks//seq.autonorm.tsv
Converging on autonormalization solution:
...............................................................................
Final normalization:    Autonormalization: 1-mers (4 total)
    A   inf%    inf%    nan
    C   inf%    inf%    nan
    G   inf%    inf%    nan
    T   inf%    inf%    nan
Autonormalization: 2-mers (16 total)
    AA  inf%    inf%    nan
    CA  inf%    inf%    nan
    GA  inf%    inf%    nan
    TA  inf%    inf%    nan
    AC  inf%    inf%    nan
    CC  inf%    inf%    nan
    GC  inf%    inf%    nan
    TC  inf%    inf%    nan
    AG  inf%    inf%    nan
    CG  inf%    inf%    nan
    GG  inf%    inf%    nan
    TG  inf%    inf%    nan
    AT  inf%    inf%    nan
    CT  inf%    inf%    nan
    GT  inf%    inf%    nan
    TT  inf%    inf%    nan
Autonormalization: 3-mers (64 total)
Finished preparing sequence/group files

----------------------------------------------------------
Known motif enrichment

Reading input files...
0 total sequences read
502 motifs loaded
Cache length = 11180
Using binomial scoring
Checking enrichment of 502 motif(s)
|0%                                    50%                                  100%|
=================================================================================

Illegal division by zero at /Users/xuenjun/Documents/CHIP-seq/Homer/bin/findKnownMotifs.pl line 152. ---------------------------------------------------------- De novo motif finding (HOMER)

Scanning input files...

!!! Something is wrong... are you sure you chose the right length for motif finding? !!! i.e. also check your sequence file!!!

Scanning input files...

!!! Something is wrong... are you sure you chose the right length for motif finding? !!! i.e. also check your sequence file!!!

-blen automatically set to 2
Scanning input files...

!!! Something is wrong... are you sure you chose the right length for motif finding? !!! i.e. also check your sequence file!!! Use of uninitialized value in numeric gt (>) at /Users/xuenjun/Documents/CHIP-seq/Homer/bin/compareMotifs.pl line 1381. !!! Filtered out all motifs!!! Job finished - if results look good, please send beer to ..

Cleaning up tmp files...
ChIP-Seq Homer • 6.9k views
ADD COMMENT
1
Entering edit mode

This once happened to me because my input files had the chromosome column in the "1","2,"3"... format, whereas HOMER's genomes have the "chr1","chr2","chr3"... format. Thus, adding "chr" to my chromosome columns solved the problem.

ADD REPLY
0
Entering edit mode

Hi, I encountered the same error message. However, I made the chromosome column names are consistent with my bed file chromosome names. Was wondering if you know some other reason I might get this error message

ADD REPLY
0
Entering edit mode

Good day,

Do you have a quick command for adding this? Greatly appreciated.

Cheers, Chris

ADD REPLY
0
Entering edit mode

mutate(Chrom = paste('chr', Chrom, sep ='')) Where Chrom is the name of your column with the chromosome number

ADD REPLY
1
Entering edit mode

Good day,

Not sure if this is relevant to many now, but to solve this problem I had to change the chromosomes from, for example '1' to 'chr1'.

I did this in Excel using the concatenate function. Please let me know if you want the gory details on how I did this. More brute force and ignorance than skill....

ADD REPLY
0
Entering edit mode

what would be the reason to cause this, I checked the peaks file, and no zero value was observed.

ADD REPLY
0
Entering edit mode

Hi! Have solved the problem? I ran into the same problem as you. I have checked all the possible problems and I am now very frustrated and confused.....

ADD REPLY
0
Entering edit mode

Hi,

Did you ever solve this? I have the same problem.

Many thanks,

Lucy

ADD REPLY
0
Entering edit mode
2.9 years ago
Fleur • 0

Hi all,

I was also running into this problem and also my BED file seemed fine. However, the trick that solved it was changing my .bed file to a .pos file by the following code:

bed2pos.pl file.bed > file.pos

I hope this also helps you guys :)

Best, Fleur

ADD COMMENT
0
Entering edit mode

This had no impact on my error message unfortunately.

Cheers, Chris

ADD REPLY
0
Entering edit mode
15 months ago
Hamidreza • 0

I had the same problem. the bed files and everything seemed to be okay. To solve it, first I changed bed file to .txt file (you can either directly use the tab-delimited file (.txt) that you generate via excel) then I used "changeNewLine.pl <filename>" as it is also recommended by homer at http://homer.ucsd.edu/homer/ngs/peakMotifs.html Then I changed the output .txt file to .bed file and used as the input for findMotifsGenome.pl and bammm! It worked

"changeNewLine.pl <filename>" is there to convert the Mac-formatted text file to a Windows/Dos/Unix formatted text file. Although I already generated my text file by Windows but it worked for me too.

another thing which might seem ridiculous :) but worked for me was that when I run several motif finding jobs on the same node at the same time, it resulted in zero output. so I let one job run and reach at least to the "homer2" step and then run the next job.

ADD COMMENT

Login before adding your answer.

Traffic: 1250 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6