Question: Trimmomatic-0.36 is generating empty files
0
gravatar for madzayasodara
2.6 years ago by
UCLA
madzayasodara10 wrote:

Hi, I'm running the following:

java -jar /home/madzays/bin/trimmomatic.jar PE -phred33 /home/madzays/data/finch_data/firstrun/test/RSFV1M_S47_L006_R1_001.fastq /home/madzays/data/finch_data/firstrun/test/RSFV1M_S47_L006_R2_001.fastq ./RSFV1M_S47_L006_R1_001_paired.fastq ./RSFV1M_S47_L006_R1_001_unpaired.fastq ./RSFV1M_S47_L006_R2_001_paired.fastq ./RSFV1M_S47_L006_R2_001_unpaired.fastq SLIDINGWINDOW:4:25 MINLEN:36

the programs seems to run:

TrimmomaticPE: Started with arguments: -phred33 /home/madzays/data/finch_data/firstrun/test/RSFV1M_S47_L006_R1_001.fastq /home/madzays/data/finch_data/firstrun/test/RSFV1M_S47_L006_R2_001.fastq ./RSFV1M_S47_L006_R1_001_paired.fastq ./RSFV1M_S47_L006_R1_001_unpaired.fastq ./RSFV1M_S47_L006_R2_001_paired.fastq ./RSFV1M_S47_L006_R2_001_unpaired.fastq SLIDINGWINDOW:4:25 MINLEN:36
Multiple cores found: Using 16 threads
Input Read Pairs: 0 Both Surviving: 0 (�%) Forward Only Surviving: 0 (�%) Reverse Only Surviving: 0 (�%) Dropped: 0 (�%)
TrimmomaticPE: Completed successfully

However,. all outputs are generated but empty. Any ideas what I might be going wrong? Thanks!

ADD COMMENTlink modified 2.6 years ago by genomax80k • written 2.6 years ago by madzayasodara10

You did not provide any information on the input files. Without this, it is much harder to diagnose the problem.

ADD REPLYlink written 2.6 years ago by lech.kaczmarczyk0

Input files are from PCR-free libraries Kapa Hyper, using TruSeq adapters, and run on HS4000 PE150 lanes. thanks! I am trying to run this in a shared cluster without root access though. When I run on my PC it works just fine.

ADD REPLYlink modified 2.6 years ago • written 2.6 years ago by madzayasodara10
1
gravatar for genomax
2.6 years ago by
genomax80k
United States
genomax80k wrote:
./RSFV1M_S47_L006_R1_001_paired.fastq

Where is ./ pointing to? Do you have write permissions in that directory? This is where things are a bit confusing since you state that output files are created but are empty. Does the program seem to end right away? If it does then perhaps it is not able to read the source files from your home directory.

ADD COMMENTlink modified 2.6 years ago • written 2.6 years ago by genomax80k

Yep! That was the problem.

ADD REPLYlink written 2.4 years ago by madzayasodara10
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1486 users visited in the last hour