Question: ERROR 127: ABYSS-P: error while loading shared libraries: libmpi.so.40: cannot open shared object file: No such file or directory
0
gravatar for freuv
2.8 years ago by
freuv20
freuv20 wrote:

Hi,

I am running ABYSS but seem to be running into issues when multithreading -- please see error message below:

ABYSS-P: error while loading shared libraries: libmpi.so.40: cannot open shared object file: No such file or directory ABYSS-P: error while loading shared libraries: libmpi.so.40: cannot open shared object file: No such file or directory ABYSS-P: error while loading shared libraries: libmpi.so.40: cannot open shared object file: No such file or directory ABYSS-P: error while loading shared libraries: libmpi.so.40: cannot open shared object file: No such file or directory ABYSS-P: error while loading shared libraries: libmpi.so.40: cannot open shared object file: No such file or directory ABYSS-P: error while loading shared libraries: libmpi.so.40: cannot open shared object file: No such file or directory ABYSS-P: error while loading shared libraries: libmpi.so.40: cannot open shared object file: No such file or directory ABYSS-P: error while loading shared libraries: libmpi.so.40: cannot open shared object file: No such file or directory ABYSS-P: error while loading shared libraries: libmpi.so.40: cannot open shared object file: No such file or directory ABYSS-P: error while loading shared libraries: libmpi.so.40: cannot open shared object file: No such file or directory ABYSS-P: error while loading shared libraries: libmpi.so.40: cannot open shared object file: No such file or directory ABYSS-P: error while loading shared libraries: libmpi.so.40: cannot open shared object file: No such file or directory make: * [cam4-1.fa] Error 127

Any guidance would be much appreciated!

Thank you.

abyss assembly • 2.0k views
ADD COMMENTlink modified 2.8 years ago • written 2.8 years ago by freuv20
1

try to set the LD_LIBRARY_PATH https://stackoverflow.com/questions/4581305/

ADD REPLYlink written 2.8 years ago by Pierre Lindenbaum130k
0
gravatar for colindaven
2.8 years ago by
colindaven2.3k
Hannover Medical School
colindaven2.3k wrote:

The conda version is very easy to install.

ADD COMMENTlink written 2.8 years ago by colindaven2.3k
0
gravatar for freuv
2.8 years ago by
freuv20
freuv20 wrote:

Hi everyone,

Thank you for your help. I re-compiled AbySS using the same version of MPI I was trying to run AbySS with, and it pulled up the correct libmpi.

Resolved!

ADD COMMENTlink written 2.8 years ago by freuv20
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1777 users visited in the last hour