Question: Could not find a version of the library!
0
gravatar for majeedaasim
2.4 years ago by
majeedaasim40
United States
majeedaasim40 wrote:

I am trying to install SPOCS software. After downloading and extracting the software files I tried to configure it as mentioned in the userguide with the command: ./configure --with-boost=/path/to/boost

I find the path to boost by typing whereis boost command, it gives me the following result

boost: /usr/include/boost

Then I used this path of boost while configuring as

./configure --with-boost=/usr/include/boost

But it gives me the following error

checking whether the Boost::Program_Options library is available... no
checking whether the Boost::Date_Time library is available... yes
configure: error: Could not find a version of the library!
boost spocs • 1.6k views
ADD COMMENTlink modified 2.4 years ago by 5heikki8.8k • written 2.4 years ago by majeedaasim40

It would help if you tell your OS and its version, and the versions of SPOCS, Boost and GCC.

ADD REPLYlink written 2.4 years ago by h.mon30k
1
gravatar for 5heikki
2.4 years ago by
5heikki8.8k
Finland
5heikki8.8k wrote:

On CentOS 7 yum install boost-program-options would solve this problem..

ADD COMMENTlink written 2.4 years ago by 5heikki8.8k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 722 users visited in the last hour