Question: Pathways Enrichment Analysis.
0
gravatar for kalyanimeha
2.1 years ago by
kalyanimeha30
New Delhi INDIA
kalyanimeha30 wrote:

I am trying to visualise the pathways map but getting some error? I Have already install ReactomePA Package.

> emapplot(x)

Error in emapplot(x) : could not find function "emapplot"
ADD COMMENTlink modified 2.1 years ago by Guangchuang Yu2.3k • written 2.1 years ago by kalyanimeha30

Isn't that part of a separate package? Have you installed loaded it (enrichplot)?

ADD REPLYlink written 2.1 years ago by genomax80k

Getting error

Warning message:

package ‘enrichplot’ is not available (for R version 3.4.3)

ADD REPLYlink written 2.1 years ago by kalyanimeha30
1

https://github.com/GuangchuangYu/enrichplot/issues/3

ADD REPLYlink written 2.1 years ago by h.mon29k

I have downloaded the zipfile and extracted file saved in r directory, but when calling the library its showing error.

> library(enrichplot)

Error: package or namespace load failed for ‘enrichplot’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):

 namespace ‘DOSE’ 3.4.0 is already loaded, but >= 3.5.1 is required

In addition: Warning message:

package ‘enrichplot’ was built under R version 3.5.0
ADD REPLYlink modified 2.1 years ago by RamRS26k • written 2.1 years ago by kalyanimeha30
2

Try Googling the exact error message, then a generic form of the error message (package was built under R version). You'll see ways to find out the root cause. Please invest some effort in solving your problems.

ADD REPLYlink written 2.1 years ago by RamRS26k
2
gravatar for Guangchuang Yu
2.1 years ago by
Guangchuang Yu2.3k
China/Guangzhou/Southern Medical University
Guangchuang Yu2.3k wrote:

install the github version will works.

devtools::install_github("GuangchuangYu/enrichplot")
ADD COMMENTlink written 2.1 years ago by Guangchuang Yu2.3k

Still getting an error.

> library(enrichplot)

Error: package or namespace load failed for ‘enrichplot’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):

namespace ‘DOSE’ 3.4.0 is already loaded, but >= 3.5.1 is required


> emapplot(yy)
Error in emapplot(yy) : could not find function "emapplot"
ADD REPLYlink modified 24 months ago by RamRS26k • written 2.1 years ago by kalyanimeha30
1
devtools::install_github(c("GuangchuangYu/DOSE", "GuangchuangYu/enrichplot"))
ADD REPLYlink written 24 months ago by Guangchuang Yu2.3k

why do you update the package at such higher frequency

ADD REPLYlink written 20 months ago by jimmy_zeng90

What does that even mean? Can you elaborate on that question please?

ADD REPLYlink written 20 months ago by RamRS26k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1265 users visited in the last hour