Question: SARTools instalation error: DESeq2 1.10.1 was found but >= 1.12.0 is required
0
gravatar for Farbod
14 months ago by
Farbod3.3k
Toronto
Farbod3.3k wrote:

Dear Biostars, Hi

In order to installing SARTools package, in Ubuntu 14.04 command line R (R version 3.3.3 RC (2017-02-27 r72279) -- "Another Canoe" ), I tried the step by step guideline from this link.

But at the last step of running : install_github("PF2-pasteur-fr/SARTools", build_vignettes=TRUE)

I recieved the error about DESeq2 version as:

* installing *source* package ‘SARTools’ ...
** R
** inst
** preparing package for lazy loading 
Error : package ‘DESeq2’ 1.10.1 was found, but >= 1.12.0 is required by ‘SARTools’ 
ERROR: lazy loading failed for package ‘SARTools’

* removing ‘/tmp/RtmpDGyIGM/Rinstfa46b09f9ed/SARTools’
ERROR: package installation failed Installation failed: Command failed (1)

I have tried to upgrade the DESeq2, but it did not solve the problem (BiocInstaller version 3.2 is too old for R version 3.3.3).

Please help me to install SARtools.

Thanks

edger rna-seq deseq2 sartools • 571 views
ADD COMMENTlink modified 14 months ago • written 14 months ago by Farbod3.3k

What is the output of .libPaths()? After you upgraded DESeq2, what is the output of sessionInfo()?

ADD REPLYlink written 14 months ago by h.mon26k

Hi,

for the .libPaths() :

[1] "/home/emami/R/x86_64-pc-linux-gnu-library/3.3"

[2] "/usr/local/lib/R/site-library"
[3] "/usr/lib/R/site-library"
[4] "/usr/lib/R/library"

and for the second :

>   
> 
> >   R version 3.3.3 RC (2017-02-27 r72279)
> >     Platform: x86_64-pc-linux-gnu (64-bit)
> >     Running under: Ubuntu 14.04.2 LTS
> >     
> >     locale:
> >      [1] LC_CTYPE=en_US.UTF-8    LC_NUMERIC=C            LC_TIME=fa_IR          
> >      [4] LC_COLLATE=en_US.UTF-8  LC_MONETARY=fa_IR       LC_MESSAGES=en_US.UTF-8
> >      [7] LC_PAPER=fa_IR          LC_NAME=C               LC_ADDRESS=C           
> >     [10] LC_TELEPHONE=C          LC_MEASUREMENT=fa_IR    LC_IDENTIFICATION=C    
> >     
> >     attached base packages:
> >     [1] stats     graphics  grDevices utils     datasets  methods   base     
> >     
> >     other attached packages:
> >     [1] devtools_1.13.5      BiocInstaller_1.20.3
> >     
> >     loaded via a namespace (and not attached):
> >      [1] Rcpp_0.12.16       digest_0.6.15      withr_2.1.2        R6_2.2.2          
> >      [5] grid_3.3.3         plyr_1.8.4         gtable_0.2.0       git2r_0.21.0      
> >      [9] scales_0.5.0.9000  httr_1.3.1         ggplot2_2.2.1.9000 pillar_1.2.2      
> >     [13] rlang_0.2.0        curl_3.2           lazyeval_0.2.1     tools_3.3.3       
> >     [17] munsell_0.4.3      colorspace_1.3-2   memoise_1.1.0      knitr_1.20        
> >     [21] tibble_1.4.2

BiocInstaller version 3.2 is too old for R version 3.3.3

ADD REPLYlink modified 14 months ago • written 14 months ago by Farbod3.3k
0
gravatar for Farbod
14 months ago by
Farbod3.3k
Toronto
Farbod3.3k wrote:

Hi,

The issue has been solved by removing BiocInstaller, and trying some other unknown scripts.

Thanks

ADD COMMENTlink modified 14 months ago • written 14 months ago by Farbod3.3k

The issue has been solved by removing BiocInstaller, and trying some other unknown scripts.

Could you elaborate? The solution as it stands now is not of much help to anyone. What are those "unknown scripts"?

ADD REPLYlink written 14 months ago by h.mon26k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 827 users visited in the last hour