EnsEMBL Perl API connection error
2
1
Entering edit mode
4.2 years ago
sophiespo ▴ 90

Hi all,

This is the first time I've had to post for help on something so if I've done it wrong I apologise.

I have been writing a script that uses the Bio::EnsEMBL::Registry API. It has been working really well and I've had no issues with it until now. I went away for a week, and upon getting back today everything seems to have been broken. To be clear, I did not change anything in the meantime, I left everything as it was, including my host logins which suffered no disconnections or anything, meaning no local variable should have changed.

Using the instructions on the API webpage, the script I am testing includes this command which now fails:

    Bio::EnsEMBL::Registry->load_registry_from_db(
      -host    => 'ensembldb.ensembl.org',
      -user    => 'anonymous',
      -verbose => '1'
   );

This is the error I get:

-------------------- EXCEPTION --------------------
MSG: Cannot connect to the Ensembl MySQL server at ensembldb.ensembl.org:3306; check your settings & DBI error message: Host **<IP address redacted>** is blocked because of many connection errors; unblock with 'mysqladmin flush-hosts'
STACK Bio::EnsEMBL::Registry::load_registry_from_db ../ensembl/modules/Bio/EnsEMBL/Registry.pm:1769
STACK toplevel ./connect.pl:13
Date (localtime)    = Mon May  7 16:21:29 2018
Ensembl API version = 92
---------------------------------------------------

I have connected to the mysql install on the host that I am trying to run this command from and performed the "flush hosts" command like it says but it hasn't fixed it.

I have been looking into this all day and I just don't know how to resolve this. Is the connection blocked on my end or the ensembldb.ensembl.org end? Is anyone else having this issue or know what I need to do to get around it? I know this error popped up with BiomaRt when ensembl changed something so could that be the issue here too?

software error • 1.3k views
ADD COMMENT
0
Entering edit mode

This error typically means that the server has received too many failed requests from your computer but I also just got the same error so I would report this to the Ensembl helpdesk. There's likely something wrong on their side. In the meantime using the mirror useastdb.ensembl.org seems to be working.

ADD REPLY
0
Entering edit mode
4.2 years ago

The issue at Ensembl has been fixed now. Many thanks for reporting it and for your patience!

ADD COMMENT
0
Entering edit mode
4.2 years ago

I am sorry that you have experienced this problem. We are aware of an issue on our side and working on a solution. I will post an update as soon as this is fixed.

ADD COMMENT

Login before adding your answer.

Traffic: 2322 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6