OBITools installation error (mac OS X)
0
0
Entering edit mode
3.7 years ago

Hi everyone, I am attempting to install OBITools and I receive the following error:

$ pip3 install OBITools
    Collecting OBITools
     Using cached    https://files.pythonhosted.org/packages/dc/53/bef677cfebef9aba707abb36f476d474c1a3d67f02fefdb38fa9fcf92b4f/OBITools-1.2.11.tar.gz
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/private/var/folders/bv/3wwlmnhs7vz0k9ffnhcx674c0000gn/T/pip-build-skycz3ut/OBITools/setup.py", line 35, in <module>
        from obidistutils.serenity import serenity_mode
      File "distutils.ext/obidistutils/serenity/__init__.py", line 12, in <module>
        import urllib2
    ModuleNotFoundError: No module named 'urllib2'

    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /private/var/folders/bv/3wwlmnhs7vz0k9ffnhcx674c0000gn/T/pip-build-skycz3ut/OBITools/

If anyone could point me in the right direction that would be great, thanks for reading!

software error python • 1.8k views
ADD COMMENT
1
Entering edit mode

It appears OBITools is for python 2 only. So pip2 install it.

ADD REPLY
0
Entering edit mode

Yes, I tried pip and pip2 to install OBITools but it reports that the command is not found.

ADD REPLY
0
Entering edit mode

What command is not found?

ADD REPLY
0
Entering edit mode

pip2 does not work. I installed pip, it seemed to work, however, I received the same error message as before.

ADD REPLY
0
Entering edit mode

Can you post the output of which -a python and which -a python3?

ADD REPLY
0
Entering edit mode
$which -a python
/usr/bin/python


$ which -a python3
/Library/Frameworks/Python.framework/Versions/3.6/bin/python3
/usr/local/bin/python3
ADD REPLY
0
Entering edit mode

I installed pip

How? Can you show which -a pip?

What about

python -m pip install OBITools
ADD REPLY
0
Entering edit mode
$ which -a pip
/Library/Frameworks/Python.framework/Versions/3.6/bin/pip

I also tried python -m pip install OBITools, and it returned /usr/bin/python: No module named pip

ADD REPLY
0
Entering edit mode

Then pip was not installed for python2

ADD REPLY
0
Entering edit mode

I installed pip, it seemed to work, however, I received the same error message as before.

The reason you are getting the same error is because pip you are using is for python3.

ADD REPLY
0
Entering edit mode

If you're not against dockers, I've made a dockerized version of the tool, which abstracts away the arduous install process. https://hub.docker.com/r/romunov/obitools

ADD REPLY

Login before adding your answer.

Traffic: 2722 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6