hisat2 was not worked
0
1
Entering edit mode
3.2 years ago

I'm having an issue running Hisat2 on Mac OS 10.13.6 . Does anybody have any suggestions on how to fix this error?

$ hisat2-build
/Mus_musculus/UCSC/mm10/Sequence/WholeGenomeFasta/genome.fa
genome_index dyld: Symbol not found:
__ZNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEED1Ev   Referenced from: /usr/local/Cellar/hisat2/2.1.0/bin/hisat2-build-s  
Expected in: /usr/lib/libstdc++.6.0.9.dylib  in
/usr/local/Cellar/hisat2/2.1.0/bin/hisat2-build-s Abort trap: 6

This is my config

$ brew config HOMEBREW_VERSION: 1.7.0 ORIGIN:
https://github.com/Homebrew/brew HEAD:
7e8fb9a0f8ab5e841763ec6c7fefa72a8462b594 Last commit: 5 days ago Core
tap ORIGIN: https://github.com/Homebrew/homebrew-core Core tap HEAD:
fa5253faa1d416851bbd3d957f67f5ccbcb15441 Core tap last commit: 5 hours
ago HOMEBREW_PREFIX: /usr/local CPU: quad-core 64-bit skylake Homebrew
Ruby: 2.3.7 =>
/usr/local/Homebrew/Library/Homebrew/vendor/portable-ruby/2.3.7/bin/ruby
Clang: 9.1 build 902 Git: 2.18.0 => /usr/local/bin/git Curl: 7.54.0 =>
/usr/bin/curl Java: 10.0.2, 1.8.0_121 macOS: 10.13.6-x86_64 CLT:
9.4.1.0.1.1528165917 Xcode: 9.4.1 XQuartz: 2.7.11 => /opt/X11

brew list is here.

$ brew list bam     ffmpeg      isl     numpy       stringtie
bedtools    gcc     jpeg        opencv      tbb blast       gcc@6       lame        openexr     wget
boost       gdbm        libidn2     openssl     x264
bowtie      gettext     libmpc      python      xvid
bowtie2     git     libpng      python@2    xz bwa      gmp     libtiff     readline
curl        hisat2      libunistring    rmtrash eigen       htslib      lmdb        samtools
fastqc      ilmbase     mpfr        sqlite

Best regards.

RNA-Seq hisat2 dyld • 2.4k views
ADD COMMENT
1
Entering edit mode

Get a precompiled binary directly from the hisat2 main page and try again.

ADD REPLY
0
Entering edit mode

Thank you very much your helpful suggestion.

I tried installing from mac binary, but it did not worked. It seems that ./configure does not work, because error returned by make. Since I can read help by hisat 2 - h, it may have been a systematic error depending on Mac OS

ADD REPLY
1
Entering edit mode

That is why I was talking about the precompiled binary. Precompiled binaries are, as the name said, already compiled by the developer, and the only thing you have to do is unpack them and then start the program. This link gives you the Mac binary. There is no need for configuring or making anything. Just do ./hisat2 and run your alignment.

ADD REPLY
0
Entering edit mode

Thank you for your advice. I really do not understand precompiled binary.

This time I succeeded in another way, but from next I will try it in the way you proceeded. Thank you so much.

ADD REPLY
1
Entering edit mode

check this link. Though it has no relevance with hisat2, but it do have with Mac OS.

ADD REPLY
0
Entering edit mode

Thank you very much.

From the conclusion. /usr/local/lib/libstdc++.6.0.9.dylib has been deleted, then working of hisat2 was started!

I tried to replace and/or remove /usr/lib/libstdc++.6.0.9.dylib, but It was failed. Terminal returned file or directly no exist, but I can find by ls. All option of rm was not worked for delting /usr/lib/libstdc++.6.0.9.dylib. For removing or /usr/lib/libstdc++.6.0.9.dylib, the file was found out from finder and transfer to trash box.

ADD REPLY
1
Entering edit mode

Looking at your situation, I think she should follow what ATpoint has mentioned. It is the most easiest way of getting HiSAT2 working.

ADD REPLY
0
Entering edit mode

I am a beginner whose operation at the terminal has only passed a week from the first time. This time, I got great advice from everyone and I learned a lot. There was an easy way and I am quite surprised. Because I am doing it alone, I am very thankful for asking questions. Please tell us a lot in future.

ADD REPLY

Login before adding your answer.

Traffic: 1137 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6