Question: Error: package or namespace load failed for ReactomePA
0
gravatar for ulapei
11 months ago by
ulapei20
ulapei20 wrote:

Hi everyone,

I was wondering if anyone knows how to fix the error below:

library(ReactomePA) Error: package or namespace load failed for ‘ReactomePA’: object ‘netplot’ is not exported by 'namespace:DOSE'

The answers I have found advice to uninstall and install the package. I have done so, but I still keep getting the same error. Package clusterProfiler works just fine. All packages and R are up to date.

Thanks!

ADD COMMENTlink modified 10 months ago by lzhizhao91790 • written 11 months ago by ulapei20
1
gravatar for ulapei
11 months ago by
ulapei20
ulapei20 wrote:

Problem was solved by running R as an administrator and manually reinstalling the packages. I believe the problem was caused by several old packages that were located in only administrator accessible Temp folder. As ReacomePA could not update those packages with regular user rights, ReactomePA which is dependent on them could not be installed.

ADD COMMENTlink written 11 months ago by ulapei20

i use Rstudio, so how to run R as an administrator ?

ADD REPLYlink written 10 months ago by lzhizhao91790

i run R as an administrator but can not solved the problem

ADD REPLYlink written 10 months ago by lzhizhao91790
0
gravatar for lzhizhao9179
10 months ago by
lzhizhao91790 wrote:

ReactomePA is shit !!! ReactomePA is shit . Do not use

ADD COMMENTlink written 10 months ago by lzhizhao91790

Tell us how you really feel

ADD REPLYlink written 10 months ago by goodez460
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1479 users visited in the last hour