Question: AttributeError: 'dict' object has no attribute '__NUMPY_SETUP__' in install of Popcorn
0
gravatar for Apprentice
2.1 years ago by
Apprentice40
Apprentice40 wrote:

Hi.

I'm trying to install Popcorn.

I got an error message when I do $ python setup.py install.

AttributeError: 'dict' object has no attribute 'NUMPY_SETUP'

Could you give me any advice to install Popcorn?

I use CentOS 7 and python 2.7.

snp python • 2.1k views
ADD COMMENTlink modified 2.0 years ago • written 2.1 years ago by Apprentice40
0
gravatar for Devon Ryan
2.1 years ago by
Devon Ryan97k
Freiburg, Germany
Devon Ryan97k wrote:

The error occurs when installing Bottleneck (I had to track this down by looking at the bug report you posted on github). Most likely you need to just pip install Bottleneck or ensure that numpy is installed.

ADD COMMENTlink written 2.1 years ago by Devon Ryan97k
0
gravatar for Apprentice
2.1 years ago by
Apprentice40
Apprentice40 wrote:

Thank you for your comment.

I already have installed Bottleneck 1.2.1 and numpy 1.15.2. But the error messages were obtained.

Do you have any other advices?

ADD COMMENTlink written 2.1 years ago by Apprentice40

No clue why those weren't seen then.

ADD REPLYlink written 2.0 years ago by Devon Ryan97k
0
gravatar for Apprentice
2.1 years ago by
Apprentice40
Apprentice40 wrote:

I attached an error message file about this problem. Please give me any advices if you noticed.

https://github.com/brielin/Popcorn/files/2440225/log.txt

ADD COMMENTlink written 2.1 years ago by Apprentice40
0
gravatar for Apprentice
2.0 years ago by
Apprentice40
Apprentice40 wrote:

Hi

My problem was solved by doing below command.

pip install -r requirements.txt

python setup.py install

Thank you for advices.

ADD COMMENTlink written 2.0 years ago by Apprentice40
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 2195 users visited in the last hour