Question: rsem prepare-reference error
0
gravatar for amithasandur
5 months ago by
amithasandur0 wrote:

Hi there,

I am trying to run "rsem-prepare-reference" using the options below:

rsem-prepare-reference commands:

  rsem-prepare-reference --gtf path/to/gtf_file \
    --star \
    --star-path path/to/STAR \
    --star-sjdboverhang 99 \
     -p 8 \
      path/to/primary_assembly_fasta_file \
      /ref/mouse_ensembl \

But I get error below:

In the ".err" file:

Cannot open mouse_ensembl.transcripts.fa! It may not exist.

In the ".out" file:

rsem-preref /ref/mouse_ensembl.transcripts.fa 1 /ref/mouse_ensembl
"rsem-preref /ref/mouse_ensembl.transcripts.fa 1 /ref/mouse_ensembl" failed! Plase check if you provide correct parameters/options for the pipeline!

Has anyone faced the same error or know how to fix this?

Thank you,

Amitha

rsem • 370 views
ADD COMMENTlink modified 5 months ago by h.mon24k • written 5 months ago by amithasandur0
0
gravatar for h.mon
5 months ago by
h.mon24k
Brazil
h.mon24k wrote:

The error message is pretty clear. The path to the transcripts fasta is incorrect. What is that "1" between the path to the file and the reference name?

The command line you have shown has nothing to do with the error message, as you edited files and paths.

ADD COMMENTlink written 5 months ago by h.mon24k

What is the transcripts fasta here?

For my case in command line, I have just provided the mouse gtf file (on 1st line) and primary assembly fa file (on 6th line).. Not sure what "/ref/mouse_ensembl.transcripts.fa" is supposed to mean??

Is it trying to generate these files or locate them? If so which transcript files is it trying to locate?

In the ".out" file, I can see the following:

"path to primary_assembly.fa is processed!

136630 transcripts are extracted.

Extracting sequences is done!

Group File is generated!

Transcript Information File is generated!

Chromosome List File is generated!

Extracted Sequences File is generated!"

rsem-preref ref/mouse_ensembl.transcripts.fa 1 ref/mouse_ensembl

"rsem-preref ref/mouse_ensembl.transcripts.fa 1 ref/mouse_ensembl" failed! Plase check if you provide correct parameters/options for the pipeline!

So are these "group file, transcript information file, chromosome list file and extracted sequences file" be generated in the directory, if so, I do not see them.

Any clarification is much appreciated!

Thanks,

Amitha

ADD REPLYlink modified 5 months ago • written 5 months ago by amithasandur0
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1512 users visited in the last hour