Question: How to fix this strand flips for Michigan Imputation Server?
2
gravatar for Sharon
4 months ago by
Sharon420
Sharon420 wrote:

Hi Every one

I am a bit stuck at this error from Michigan Imputation Server, does any one know what this error means and any hint to fix?

Error: More than 100 obvious strand flips have been detected. Please check strand. Imputation cannot be started!

Statistics: 
Alternative allele frequency > 0.5 sites: 0
Reference Overlap: 99.80% 
Match: 426,485
Allele switch: 66,772
Strand flip: 23,263
Strand flip and allele switch: 13,805
A/T, C/G genotypes: 642
Filtered sites: 
Filter flag set: 0
Invalid alleles: 0
Duplicated sites: 286
NonSNP sites: 0
Monomorphic sites: 0
Allele mismatch: 465
SNPs call rate < 90%: 0

Thanks

snp imputation • 556 views
ADD COMMENTlink modified 4 months ago by Shicheng Guo7.4k • written 4 months ago by Sharon420
4
gravatar for Shicheng Guo
4 months ago by
Shicheng Guo7.4k
Shicheng Guo7.4k wrote:

Check the strand and switching just like before to use beagle:

http://faculty.washington.edu/sguy/beagle/strand_switching/strand_switching.html

or try this simple tool:

https://github.com/biocore-ntnu/snpflip

beagle also provide a tool called conform-gt https://faculty.washington.edu/browning/conform-gt.html

a program for making alleles in a VCF file to be consistent with a reference VCF file

another data clean tools is: checkVCF https://github.com/zhanxw/checkVCF

Anyway, clear the data as much as possible before the imputation and phasing.

ADD COMMENTlink modified 4 months ago • written 4 months ago by Shicheng Guo7.4k

Never used beagle. I will check this out and see. Thanks a lot

ADD REPLYlink written 4 months ago by Sharon420

Hi,

did you try to use any of those tools and did they work for you? I am having the same problem.

Thanks Ana

ADD REPLYlink written 3 months ago by anamaria0

Still trying anamaria. I will post my answer here if it works out.

ADD REPLYlink written 3 months ago by Sharon420

thank you, I hope you succeed!

ADD REPLYlink written 3 months ago by anamaria0

I used Beagle it self and it works with me with no issues like the server.

ADD REPLYlink written 3 months ago by Sharon420

Hi Sharon,

Good to hear that! Can you please post all steps you used to do imputation on Beagle?

Thanks

ADD REPLYlink modified 29 days ago • written 29 days ago by anamaria0
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1075 users visited in the last hour