Question: SPAdes stuck for almost 24h, restart it didn't work
0
gravatar for lucia
18 months ago by
lucia10
lucia10 wrote:

SPAdes stuck for almost 24h, restart it didn't work. I wonder it is because of the fastq file or the software or the server.

39 8 0 nslots: 2147483648 bits per slot: 8 range: 0000008000000000  
0:02:23.951     2G / 2G    INFO   K-mer Counting          
(kmer_data.cpp             : 317)   Processing
/public/home/data/cleandata/NDME07825_output/NDME07825_paired_1.fastq 
0:11:23.927     2G / 2G    INFO   K-mer Counting          
(kmer_data.cpp             : 326)   Processed 23006870 reads  
0:11:23.927     2G / 2G    INFO   K-mer Counting          
(kmer_data.cpp             : 317)   Processing
/public/home/data/cleandata/NDME07825_output/NDME07825_paired_2.fastq

Has anyone had this problem before? Dying for suggestions and solutions.

spades • 567 views
ADD COMMENTlink modified 18 months ago by Joe17k • written 18 months ago by lucia10

How large is your fastq file? Have you had other assemblies complete successfully?

ADD REPLYlink written 18 months ago by Joe17k

My fastq file is 7.74G, and I have had other assemblies complete well.

ADD REPLYlink written 18 months ago by lucia10

And the log file of another fastq file that also faced this problem shows these:

=== Stack Trace === [0x40a709] [0x40a876] [0x5b3220] [0x48a3f7] [0x441977] [0x439b98] [0x59a7ae] [0x5ab8c4] [0x60b969]


== Error ==  system call for: "['/public/home/biotools/SPAdes-3.12.0-Linux/bin/spades-hammer', '/public/home/data/assembly/NDME07821/corrected/configs/config.info']" finished abnormally, err code: 1

In case you have troubles running SPAdes, you can write to spades.support@cab.spbu.ru or report an issue on our GitHub repository github.com/ablab/spades Please provide us with params.txt and spades.log files from the output directory.
ADD REPLYlink modified 18 months ago by genomax85k • written 18 months ago by lucia10

Hello Lucia, good to see you. Try to increase the number of threads with -t parameter, e.g., -t 8 is 8 threads. Error code 1 is a segmentation fault, I believe. Obviously, also ensure that you are using enough RAM.

ADD REPLYlink written 18 months ago by Kevin Blighe61k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1678 users visited in the last hour