Question: (Closed) CPAN perl module installed failed
0
gravatar for IrisChang
3 months ago by
IrisChang0
IrisChang0 wrote:

Hi,

I am trying to use Pfam, but everytime I got the same message below.

Can't locate Moose.pm in @INC (@INC contains: /usr/lib64/qt-3.3/bin /home/program/apache-maven-3.3.9/bin /usr/local/bin /usr/bin /usr/local/sbin /usr/sbin /home/ching/program/perl.sr /home/ching/.local/bin /home/ching/bin /home/ching/program/trinityrnaseq-2.2.0 /home/ching/program/samtools-1.3.1 /home/ching/program/bowtie2-2.2.9/ /home/ching/program/bwa-0.7.15/ /home/ching/program/picard-tools-2.5.0/ /home/program/ncbi-blast-2.3.0+/bin/ /home/program/bowtie2-2.2.9/ /home/program/tophat-2.1.1.Linux_x86_64/ /home/program/cufflinks-2.2.1.Linux_x86_64/ /home/program/Trimmomatic-0.36/ //home/ching/program/hmmer/hmmer-3.2.1/src /home/ching/program/Pfam/PfamScan/ /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at /home/ching/program/Pfam/PfamScan//Bio/Pfam/HMM/HMMResultsIO.pm line 50. 
BEGIN failed--compilation aborted at /home/ching/program/Pfam/PfamScan//Bio/Pfam/HMM/HMMResultsIO.pm line 50.
Compilation failed in require at /home/ching/program/Pfam/PfamScan//Bio/Pfam/Scan/PfamScan.pm line 33.
BEGIN failed--compilation aborted at /home/ching/program/Pfam/PfamScan//Bio/Pfam/Scan/PfamScan.pm line 33.
Compilation failed in require at /home/ching/program/Pfam/PfamScan/pfam_scan.pl line 8.
BEGIN failed--compilation aborted at /home/ching/program/Pfam/PfamScan/pfam_scan.pl line 8.`

So I installed Moose by the command line

cpan
install Moose

But I got the error message

Running make install  
[sudo] password for Irischang:  
ching is not in the sudoers file.  This incident will be reported.  
ETHER/Moose-2.2011.tar.gz  
sudo /usr/bin/make install  -- NOT OK  
Failed during this command:  
 RJBS/Test-Fatal-0.014.tar.gz                 : install NO  
 ETHER/Module-Metadata-1.000033.tar.gz        : install NO  
 LEONT/CPAN-Meta-Check-0.014.tar.gz           : install NO  
 RJBS/Sub-Install-0.928.tar.gz                : install NO  
 DAGOLDEN/File-pushd-1.016.tar.gz             : install NO  
 HAARG/Test-Needs-0.002005.tar.gz             : install NO  
 ETHER/Test-Warnings-0.026.tar.gz             : install NO  
 TOKUHIROM/Test-Requires-0.10.tar.gz          : install NO  
 VPIT/Variable-Magic-0.62.tar.gz              : install NO  
 ETHER/B-Hooks-EndOfScope-0.24.tar.gz         : install NO  
 RIBASUSHI/namespace-clean-0.27.tar.gz        : install NO  
 ETHER/Test-CleanNamespaces-0.24.tar.gz       : install NO  
 RJBS/Sub-Exporter-0.987.tar.gz               : install NO  
 PEVANS/Scalar-List-Utils-1.50.tar.gz         : install NO  
 HAARG/MRO-Compat-0.13.tar.gz                 : install NO  
 DOY/Dist-CheckConflicts-0.11.tar.gz          : install NO  
 DOY/Package-Stash-0.37.tar.gz                : install NO  
 ILMARI/Devel-OverloadInfo-0.005.tar.gz       : install NO  
 ZEFRAM/Module-Runtime-0.016.tar.gz           : install NO  
 DROLSKY/Module-Implementation-0.09.tar.gz    : install NO  
 RJBS/Data-OptList-0.110.tar.gz               : install NO  
 ETHER/Class-Load-0.25.tar.gz                 : install NO  
 ETHER/Class-Load-XS-0.10.tar.gz              : install NO  
 ETHER/Try-Tiny-0.30.tar.gz                   : install NO  
 DROLSKY/Devel-StackTrace-2.03.tar.gz         : install NO  
 DOY/Eval-Closure-0.14.tar.gz                 : install NO  
 ETHER/Sub-Name-0.21.tar.gz                   : install NO  
 RGARCIA/Sub-Identify-0.14.tar.gz             : install NO  
 FREW/Sub-Exporter-Progressive-0.001013.tar.gz: install NO  
 HAARG/Devel-GlobalDestruction-0.14.tar.gz    : install NO  
 ETHER/Module-Runtime-Conflicts-0.003.tar.gz  : install NO  
 DROLSKY/Package-DeprecationManager-0.17.tar.gz: install NO  
 DOY/Package-Stash-XS-0.28.tar.gz             : install NO  
 ADAMK/Params-Util-1.07.tar.gz                : install NO  
 ETHER/Moose-2.2011.tar.gz                    : install NO

Same command lines were used to install the one of perl module mentioned in the error message, but it still ran into error showed below

Reading '/home/Irischang/.cpan/Metadata'  
  Database was generated on Thu, 27 Dec 2018 06:54:12 GMT  
Running install for module 'Module::Runtime'  
Running make for Z/ZE/ZEFRAM/Module-Runtime-0.016.tar.gz  
Checksum for /home/Irischang/.cpan/sources/authors/id/Z/ZE/ZEFRAM/Module-Runtime-0.016.tar.gz ok  
Scanning cache /home/Irischang/.cpan/build for sizes............................................................................DONE  
CPAN.pm: Building Z/ZE/ZEFRAM/Module-Runtime-0.016.tar.gz  
Created MYMETA.yml and MYMETA.json  
Creating new 'Build' script for 'Module-Runtime' version '0.016'  
Building Module-Runtime  
  ZEFRAM/Module-Runtime-0.016.tar.gz
  ./Build -- OK  
Running Build test  
t/cmn.t ............. ok  
t/dependency.t ...... ok  
t/import_error.t .... ok  
t/ivmn.t ............ ok  
t/ivms.t ............ ok  
t/mnf.t ............. ok  
t/pod_cvg.t ......... skipped: Test::Pod::Coverage not available  
t/pod_syn.t ......... skipped: Test::Pod not available  
t/rm.t .............. ok  
t/taint.t ........... ok  
t/um.t .............. ok  
t/upo.t ............. ok  
t/upo_overridden.t .. ok  
All tests successful.  
Files=13, Tests=365,  0 wallclock secs ( 0.09 usr  0.02 sys +  0.45 cusr  0.13 csys =  0.69 CPU)  
Result: PASS  
  ZEFRAM/Module-Runtime-0.016.tar.gz
  ./Build test -- OK  
Running Build install  
[sudo] password for Irischang:  
Irischang is not in the sudoers file.  This incident will be reported.  
  ZEFRAM/Module-Runtime-0.016.tar.gz  
  sudo ./Build install  -- NOT OK    
Failed during this command:  
 ZEFRAM/Module-Runtime-0.016.tar.gz           : install NO

Perl version is v5.16.3

Does anyone know how to fix it?
Thanks for any suggestion

software error • 386 views
ADD COMMENTlink modified 3 months ago • written 3 months ago by IrisChang0

You will need to install modules into your own space since you don't have admin privileges.

ADD REPLYlink written 3 months ago by genomax65k

Thanks for your reply. But when I compile the code, it pop out the following error

Your toolchain doesn't support configure_requires, so Dist::CheckConflicts
hasn't been installed yet. You should check for conflicting modules
manually using the 'moose-outdated' script that is installed with
this distribution once the installation finishes.

Warning: prerequisite Modules not found.

And I try to install the module mention above and use su user to do it, similar error message pop out. It seems to be a privileges error, but I have no idea how to fix it.

ADD REPLYlink written 3 months ago by IrisChang0

Hello IrisChang!

We believe that this post does not fit the main topic of this site.

Pure Perl question. Please search StackOverflow/talk to your sysadmin

For this reason we have closed your question. This allows us to keep the site focused on the topics that the community can help with.

If you disagree please tell us why in a reply below, we'll be happy to talk about it.

Cheers!

ADD REPLYlink written 3 months ago by RamRS21k
Please log in to add an answer.
The thread is closed. No new answers may be added.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1082 users visited in the last hour