Question: Portal_client No such file or directory via ascp
0
gravatar for kutanfurkan7
9 months ago by
kutanfurkan70 wrote:

Hello everyone , Today I tried downloading data from hmpdac via portal_client(data_tool I use with python link=https://github.com/IGS/portal_client ).I downloaded successfully aspera manifest.tv.Below code inside aspera_manifest.tsv

id  md5 size    urls
07c6c17c2b6f11e98849ef9e212bebbd    ed8e04692fc34da01ee9c430612f6b58    3363519 fasp://aspera.hmpdacc.org/ptb/genome/microbiome/16s/hm16str/EP843963_K10_MCKD.trimmedseqset.fasta.gz

This is working image.

work

However, I downloaded diffrent aspera_manifest.tsv from hmpdac but this is not work It say no such file or directory.Below code is diffrent_manifest.tsv inside:

file_id md5 size    urls    sample_id
1419f08f554e0c93f3b62fe90c0db7cf    1aafd7a4515c22d131351a05b9528d3d    15322124    fasp://aspera2.ihmpdcc.org/ibd/genome/microbiome/wgs/analysis/hmmrc/CSM79HJY_genefamilies_relab.biom    1419f08f554e0c93f3b62fe90c0d9dfd
1419f08f554e0c93f3b62fe90c0db842    eefaffea20601799c1eb28708093dc17    596905  fasp://aspera2.ihmpdcc.org/ibd/genome/microbiome/wgs/analysis/hmmrc/CSM79HJY_ecs_relab.biom 1419f08f554e0c93f3b62fe90c0d9dfd
1419f08f554e0c93f3b62fe90c0dccc1    cd0637cf3284946e583b04a2a48f58d3    16474   fasp://aspera2.ihmpdcc.org/ibd/genome/microbiome/wgs/analysis/hmscp/CSM79HJY_taxonomic_profile.biom 1419f08f554e0c93f3b62fe90c0d9dfd
1419f08f554e0c93f3b62fe90c0dc1c7    feee2bb8eaf7932cbbe5de750b770387    83427   fasp://aspera2.ihmpdcc.org/ibd/genome/microbiome/wgs/analysis/hmmrc/CSM79HJY_pathabundance_relab.biom   1419f08f554e0c93f3b62fe90c0d9dfd

This is error image:

error

Have a any idea ? How Can I solve this problem?Thanks for your comment.

aspera ascp python hmpdac • 396 views
ADD COMMENTlink modified 9 months ago • written 9 months ago by kutanfurkan70
2

kutanfurkan7 : Can you tell how how this question is different than this one from before: Portal_client no valid url in the manifest file error

ADD REPLYlink modified 9 months ago • written 9 months ago by genomax75k

Hi genomax , before situation depands on url , It didnt find url via portal_client I solved that but now It is finding url and It generate new problem(file not found)I dont understand maybe file location wrong or server problem. (First code use aspera.hmpp server but other use aspera2.ihmpdac) .In addition I checked my ssh and It opened.(port 22 tcp and 33001 udp)Thank for your comment.

ADD REPLYlink modified 9 months ago • written 9 months ago by kutanfurkan70
1

Have you tried to put just one entry in the .tsv file to see if things work before putting in several?

Posting screen shots like ones above does not help since we can't see the command you are actually running. You should edit the original post and paste the exact command you are trying to run.

ADD REPLYlink written 9 months ago by genomax75k
1

Please edit your post using : How to add images to a Biostars post

ADD REPLYlink modified 9 months ago • written 9 months ago by Bastien Hervé4.5k

Plus all links broken. Please fix.

ADD REPLYlink modified 9 months ago • written 9 months ago by ATpoint26k

do you see? Check please

ADD REPLYlink written 9 months ago by kutanfurkan70

If you can see your pictures in the preview then it is all good. Yes we can see them now thanks

ADD REPLYlink written 9 months ago by Bastien Hervé4.5k

I thank for your comment

ADD REPLYlink written 9 months ago by kutanfurkan70
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 808 users visited in the last hour