Question: error RepeatMasker Installation
0
gravatar for Chironex
7 months ago by
Chironex20
rome
Chironex20 wrote:

I was installing repeatsmasker and it apparently seems to work because it shows "Congratulations! RepeatMasker is now ready to use." But when I run it it reports "Can't locate Text/Soundex.pm...". so I installed the module by "sudo cpan Text::Soundex", and by the end it tells me "Text::Soundex is up to date (3.05)." It seems the module is already installed, but RepeatMasker still has the same problem, as I'll show you in this code:

fragua@picci:~/RM/RepeatMasker$ sudo cpan Text::Soundex
Loading internal null logger. Install Log::Log4perl for logging messages
Reading '/home/fragua/.cpan/Metadata'
  Database was generated on Fri, 19 Apr 2019 22:17:03 GMT
Text::Soundex is up to date (3.05).

fragua@picci:~/RM/RepeatMasker$ ./RepeatMasker -s -lib /home/fragua/RepeatScout-1.0.5/ObiINK5k_repeats_filtered1.fasta /home/fragua/Documenti/Workdirectory/ObiINC5k.fa
Can't locate Text/Soundex.pm in @INC (you may need to install the Text::Soundex module) (@INC contains: /home/fragua/RM/RepeatMasker /home/fragua/perl5/lib/perl5 /home/fragua/anaconda/lib/site_perl/5.26.2/x86_64-linux-thread-multi /home/fragua/anaconda/lib/site_perl/5.26.2 /home/fragua/anaconda/lib/5.26.2/x86_64-linux-thread-multi /home/fragua/anaconda/lib/5.26.2 .) at /home/fragua/RM/RepeatMasker/Taxonomy.pm line 80.
BEGIN failed--compilation aborted at /home/fragua/RM/RepeatMasker/Taxonomy.pm line 80.
Compilation failed in require at ./RepeatMasker line 310.
BEGIN failed--compilation aborted at ./RepeatMasker line 310.

I installed RepeatMasker in another computer without problems, but I don't know why now I encontered this problem

perl • 332 views
ADD COMMENTlink modified 5 months ago by Biostar ♦♦ 20 • written 7 months ago by Chironex20

can you check where the Soundex.pm is installed. Is that path include in @INC ? (would be a bit weird not to be so, but wont hurt checking it anyways)

ADD REPLYlink written 7 months ago by lieven.sterck6.3k

I solved the problem. thank you anyway

ADD REPLYlink written 7 months ago by Chironex20

perhaps briefly explain how you solved it , might be useful for future reference (and/or other users encountering the same issue). thx

ADD REPLYlink written 7 months ago by lieven.sterck6.3k
1
gravatar for Chironex
7 months ago by
Chironex20
rome
Chironex20 wrote:

there were two build of perl installed. One of them was in my PATH. So i Chosen this one and the I installed Text::Soundex using sudo cpan

ADD COMMENTlink written 7 months ago by Chironex20
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1893 users visited in the last hour