Question: Error IsoformSwitchAnalyzeR with kallisto data and ensembl annotation gtf
0
gravatar for dina.hesham139
11 weeks ago by
Egypt
dina.hesham139120 wrote:

Hi, I 'm trying to analyze my kallisto data with IsoformSwitchAnalyzeR but I get this error when I use the importRdata function, I get this error:

> aSwitchList <- importRdata(
+   isoformCountMatrix   = mySwitchList$counts,
+   isoformRepExpression = mySwitchList$abundance,
+   designMatrix         = designMatrix,
+   isoformExonAnnoation = "/rice/Oryza_sativa.IRGSP-1.0.37.gtf",
+   showProgress = T)
Step 1 of 6: Checking data...
Step 2 of 6: Obtaining annotation...
    importing GTF (this may take a while)
converting annotated CDSs
Error in importRdata(isoformCountMatrix = mySwitchList$counts, isoformRepExpression = mySwitchList$abundance,  : 

The annotation and quantification (count/abundance matrix and isoform annotation) seems to be different (jacard similarity < 0.95). 
Either isforoms found in the annotation are not quantifed or vise versa. 
Specifically:
 42346 isoforms were quantified.
 98663 isoforms are annotated.
 Only 42346 overlap.

This combination cannot be analyzed since it will cause discrepencies between quantification and annotation thereby skewing all analysis.

Please make sure they belong together and try again. For more info see the FAQ in the vignette.
ADD COMMENTlink modified 10 days ago by harry0 • written 11 weeks ago by dina.hesham139120

Could you update to IsoformSwitchAnalyzeR 1.5.11 (remember to restart R after installation) and try again?

ADD REPLYlink written 10 weeks ago by kristoffer.vittingseerup2.0k

I will try Thank you!

ADD REPLYlink modified 10 weeks ago • written 10 weeks ago by dina.hesham139120

Let me know if you run into more troubles :-)

ADD REPLYlink written 10 weeks ago by kristoffer.vittingseerup2.0k

I also have same problem and i have latest version then why is it show this error

ADD REPLYlink written 10 days ago by harry0

If you use the latest version of IsoformSwitchAnalyzeR it gives this error because the files provided does not match. If you want help looking more into it please don't hesitate to ask in the google group or github - and remember to provide more information about which files you are using - the code you run and the actual error message you get.

ADD REPLYlink written 5 days ago by kristoffer.vittingseerup2.0k
0
gravatar for liuwei
4 weeks ago by
liuwei0
Shanghai
liuwei0 wrote:

My R version was 3.5.1, however, I cann't install IsoformSwitchAnalyzeR 1.5.11 or IsoformSwitchAnalyzeR 1.6.0 with conda

ADD COMMENTlink written 4 weeks ago by liuwei0

For R-3.5.1 you can get IsoformSwitchAnalyzeR 1.5.11 from github via the following command:

if (!requireNamespace("devtools", quietly = TRUE)){
    install.packages("devtools")
}
devtools::install_github("kvittingseerup/IsoformSwitchAnalyzeR", build_vignettes = TRUE)
ADD REPLYlink written 4 weeks ago by kristoffer.vittingseerup2.0k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1054 users visited in the last hour