Question: XVector install error
0
gravatar for s1469060
9 months ago by
s146906010
s146906010 wrote:

Hi all

I'm trying to load the XVector package into R studio. I installed the package via R (which is correctly synced to Rstudio) and is successful- version 3.6 of R and version 3.9 of XVector. However whilst the library appears on my list I won't load properly.

Error as follows:

library(XVector)
Error: package or namespace load failed for ‘XVector’:
 .onLoad failed in loadNamespace() for 'XVector', details:
  call: .Call(.NAME, ..., PACKAGE = PACKAGE)
  error: "externalptr_new" not available for .Call() for package "XVector"

I have loaded the package xptr too, but that hasn't solved it so I'm unsure what package is missing? Or if it is a different problem all together?

Any help would be greatly appreciated!

Thanks, all the best,

Zoe

R • 367 views
ADD COMMENTlink modified 9 months ago • written 9 months ago by s146906010

Actually, it may be a problem with the isnullptr package which appears to be correctly installed, and is in my library. However when I try to load gives the error:

library(isnullptr)
Error: package or namespace load failed for ‘isnullptr’ in FUN(X[[i]], ...):
 no such symbol isnullptr_ in package C:/Program Files/R/R-3.6.0/library/isnullptr/libs/x64/isnullptr.dll

I have checked in the folder and isnullptr.dll exists??

ADD REPLYlink modified 9 months ago • written 9 months ago by s146906010

Please use the code option to highlight code. This much improves the readability of your posts:

enter image description here

ADD REPLYlink written 9 months ago by ATpoint29k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1115 users visited in the last hour