Question: S4Vectors install error
0
gravatar for s1469060
6 months ago by
s146906010
s146906010 wrote:

Hi all

I am trying to install packages into my Rstudio. Running R version: 3.4.4. However the packages seem to download fine but then won't load for a lot of them? So for S4Vectors the download proceeded as follows:

> biocLite("S4Vectors")
BioC_mirror: https://bioconductor.org
Using Bioconductor 3.6 (BiocInstaller 1.28.0), R 3.4.4 (2018-03-15).
Installing package(s) ‘S4Vectors’
trying URL 'https://bioconductor.org/packages/3.6/bioc/bin/windows/contrib/3.4/S4Vectors_0.16.0.zip'
Content type 'application/zip' length 2653765 bytes (2.5 MB)
downloaded 2.5 MB

package ‘S4Vectors’ successfully unpacked and MD5 sums checked

The downloaded binary packages are in
    C:\Users\sejjzcr\AppData\Local\Temp\Rtmp8MmDrg\downloaded_packages
Old packages: 'checkmate', 'cluster', 'nlme', 'RcppArmadillo'
Update all/some/none? [a/s/n]: 
a

  There are binary versions available but the source versions are later:
                   binary      source needs_compilation
checkmate           1.9.1       1.9.3              TRUE
cluster             2.0.8       2.0.9              TRUE
nlme              3.1-137     3.1-140              TRUE
RcppArmadillo 0.9.300.2.0 0.9.400.3.0              TRUE

  Binaries will be installed
trying URL 'https://cran.rstudio.com/bin/windows/contrib/3.4/checkmate_1.9.1.zip'
Content type 'application/zip' length 735324 bytes (718 KB)
downloaded 718 KB

trying URL 'https://cran.rstudio.com/bin/windows/contrib/3.4/cluster_2.0.8.zip'
Content type 'application/zip' length 588040 bytes (574 KB)
downloaded 574 KB

trying URL 'https://cran.rstudio.com/bin/windows/contrib/3.4/nlme_3.1-137.zip'
Content type 'application/zip' length 2344000 bytes (2.2 MB)
downloaded 2.2 MB

trying URL 'https://cran.rstudio.com/bin/windows/contrib/3.4/RcppArmadillo_0.9.300.2.0.zip'
Content type 'application/zip' length 2241393 bytes (2.1 MB)
downloaded 2.1 MB

package ‘checkmate’ successfully unpacked and MD5 sums checked
package ‘cluster’ successfully unpacked and MD5 sums checked
package ‘nlme’ successfully unpacked and MD5 sums checked
package ‘RcppArmadillo’ successfully unpacked and MD5 sums checked

The downloaded binary packages are in
    C:\Users\sejjzcr\AppData\Local\Temp\Rtmp8MmDrg\downloaded_packages

But then when I try and load the library it gives an error (which I can't seem to google my way around):

> library(S4Vectors)
Error: package or namespace load failed for ‘S4Vectors’:
 .onLoad failed in loadNamespace() for 'S4Vectors', details:
  call: .Call(.NAME, ..., PACKAGE = PACKAGE)
  error: "make_RAW_from_NA_LLINT" not available for .Call() for package "S4Vectors"

I get the same sort of error for GenomicRanges, BSgenome, Xvector, so all the good stuff...

Is this to do with the binary packages being in a different folder to the package downloads? I work on a university managed desktop but have had privileges to download into the folder where my packages (not the binary versions) are being downloaded, and I can see them in the R folder library there, so they do seem to download fine?

Any insight would be much appreciated, thanks all!

All the best, Zoe

rna-seq R • 246 views
ADD COMMENTlink written 6 months ago by s146906010

You should post this on the Bioconductor support forum. I have a hunch this has to do with the version of Bioconductor you're using.

ADD REPLYlink written 6 months ago by RamRS25k

Have done, thanks for the tip!

All the best, Zoe

ADD REPLYlink written 6 months ago by s146906010
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 741 users visited in the last hour