Trimmomatic output file Issue
1
0
Entering edit mode
3.4 years ago
akh22 ▴ 80

Hi,

Using brew installed trimmomatic/0.38 and run a following script;

java -Xms4000M -Xmx12000m -XX:+UseConcMarkSweepGC \
        -XX:NewSize=300M -XX:MaxNewSize=300M \
        -jar /usr/local/Cellar/trimmomatic/0.38/libexec/trimmomatic-0.38.jar \
        PE -threads 24 -trimlog sample1_R1_001.fastq.gz  Sample2_R2_001.fastq.gz\
        ~/Desktop/output_forward_paired.fq.gz ~/Desktop/output_forward_unpaired.fq.gz\
        ~/Desktop/output_reverse_paired.fq.gz ~/Desktop/output_reverse_unpaired.fq.gz\
        ILLUMINACLIP:/usr/local/Cellar/trimmomatic/0.38/share/trimmomatic/adapters/TruSeq3-PE-2.fa:2:30:10\
        LEADING:3 TRAILING:3 SLIDINGWINDOW:4:15 MINLEN:36

I get this an error code;

Exception in thread "main" java.io.FileNotFoundException: /Volumes/Documents/ahoji/Desktop/output_forward_paired.fq.gz (No such file or directory)
at java.base/java.io.FileInputStream.open0(Native Method)
at java.base/java.io.FileInputStream.open(FileInputStream.java:213)
at java.base/java.io.FileInputStream.<init>(FileInputStream.java:155)
at org.usadellab.trimmomatic.fastq.FastqParser.parse(FastqParser.java:135)
at org.usadellab.trimmomatic.TrimmomaticPE.process(TrimmomaticPE.java:268)
at org.usadellab.trimmomatic.TrimmomaticPE.run(TrimmomaticPE.java:555)
at org.usadellab.trimmomatic.Trimmomatic.main(Trimmomatic.java:80)

I though this might be the file permission issue and I changed output directories to different directories but I still get the same error. I'd really appreciate any help on this.

Thanks in advance.

java -version java version "12.0.1" 2019-04-16 Java(TM) SE Runtime
Environment (build 12.0.1+12) Java HotSpot(TM) 64-Bit Server VM (build
12.0.1+12, mixed mode, sharing)


sw_vers
ProductName:    Mac OS X
ProductVersion: 10.14.5
BuildVersion:   18F132
RNA-Seq sequencing • 2.0k views
ADD COMMENT
0
Entering edit mode

What happens if you remove the ~/Desktop/ from all the output files? I believe Trimmomatic outputs the files in the current working directory.

ADD REPLY
0
Entering edit mode

As a quick sanity check, can you check that /Volumes/Documents/ahoji/Desktop/ exists?

i.e. ls /Volumes/Documents/ahoji/Desktop/

ADD REPLY
0
Entering edit mode

Thanks for all the suggestions, though Damian's comment fixed it. I completely missed trimlog location and after specifying the location, it run just fine. Luckily, trimmomatic did not run completely to erase fastqs.

ADD REPLY
0
Entering edit mode

If an answer was helpful, you should upvote it; if the answer resolved your question, you should mark it as accepted. You can accept more than one if they work.
Upvote|Bookmark|Accept

ADD REPLY
3
Entering edit mode
3.4 years ago

It looks like you are not specifying an output file for the -trimlog parameter. So it thinks your output_forward_paired.fq.gz is an input.

I hope you still can still redownload sample1_R1_001.fastq.gz, because it might have been overwritten.

ADD COMMENT

Login before adding your answer.

Traffic: 1148 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6