Question: clusterProfiler::enrichGO() is getting very slow
0
gravatar for sangram_keshari
7 months ago by
sangram_keshari230 wrote:

I am trying to run clusterProfiler::enrichGO() for 10 Human Ensemble IDs but its getting very slow. Sometimes it takes 15 minutes and other time more than half an hour. Also, its taking all the available RAM in a 8GB machine.

My R session dosn't have any other loaded package or objects.

I am using r=3.5 and clusterprofiler=3.10.1

Similar issue reported earlier: https://github.com/GuangchuangYu/clusterProfiler/issues/155

Even from what I remember it wasn't taking this long when I run few months back.

Any help or an alternatives which support as many organisms internally (with OrgDB) like this package does.

go clusterprofiler R • 302 views
ADD COMMENTlink modified 7 months ago by jared.andrews075.0k • written 7 months ago by sangram_keshari230

Guangchuang Yu Any known issue with newer version or R?

ADD REPLYlink written 7 months ago by sangram_keshari230
0
gravatar for jared.andrews07
7 months ago by
jared.andrews075.0k
St. Louis, MO
jared.andrews075.0k wrote:

Swap your identifiers to Entrez IDs. I don't know why, but clusterProfiler doesn't love other types of identifiers. I ran into the same issues trying to use both gene symbols and Ensemble IDs, but swapping them to Entrez IDs fixed it.

ADD COMMENTlink written 7 months ago by jared.andrews075.0k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1403 users visited in the last hour